[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265892: Bug#265851: korganizer: Upgrade to 3.2.3-1 fails

# THESE BUGS REALLY BELONG TO kdelibs-bin, kdelibs4, kdelibs-data, as in
# james' report. But I am keeping then in korganizer so they are easily
# found by other people in the same situation.

package kdelibs-bin
reassign 265892 korganizer

package korganizer
severity 265892 important
severity 265853 important
merge 265851 265853 265892


* Christian Perrier [Sun, 15 Aug 2004 12:56:42 +0200]:

> While upgrading to the latest release today:

> /var/cache/apt/archives/korganizer_4%3a3.2.3-1_i386.deb (--unpack):
>  trying to overwrite /etc/kde3/khotnewstuffrc', which is also in package
> kdelibs-bin

* Jesus Roncero [Sun, 15 Aug 2004 13:05:18 +0200]:

> On updating my system, apt-get failed to upgrade korganizer. I purged it
> with dpkg -P and tried to reinstall it, but it fails to do so as it
> founds a common file in the kdelibs-bin package. Here is the output of
> apt-get:

> My version of kdelibs-bin is:
> terminus:~# apt-cache policy kdelibs-bin
> kdelibs-bin:
>   Installed: 4:3.3.0-1

* james mcguire [Sun, 15 Aug 2004 08:19:31 -0700]:

> I have installed the latest version of kde on the debian's 
> servers - the 4:3.3.0-1 in unstable.  I am unable to install 
> KOrganizer (latest version is 4:3.2.3-1).  This is the error 
> I get:

  this is all because  kdelibs-bin, kdelibs4, kdelibs-data do
  "Replace: korganizer (<< 4:3.3.0)" but don't conflict with it.

  (which it may be justified, since using the corresponding Conflicts
  line would prevent anyone from using the uploaded KDE 3.3 parts until
  kdepim 3.3 gets available, which will take a while since it requires
  NEW processing. and kdepim 3.2.3 was uploaded on Aug 3rd, so many
  people won't see this problem).

  as for the solution, I recommend the following to anyone reading this:

    # dpkg  --force-overwrite -i korganizer_3.2.3-1_i386.deb
    # apt-get install --reinstall kdelibs-bin kdelibs4 kdelibs-data

  thanks all for your patience,

Adeodato Simó
    EM: asp16 [ykwim] alu.ua.es | PK: DA6AE621
You've come to the right place.  At debian-devel we are always willing
to argue over the meanings of words.
                -- seen on debian-devel@l.d.o

Reply to: