[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Rebuilds required for OpenEXR-dependent packages.

Hi everyone,

Sorry about the short notice, but I've been extremely busy and only got
around to updating my packages in the last few days.

The following three packages:

kdelibs4 4:3.2.92-1
kdegraphics-kfile-plugins 4:3.2.92-1
exrtools 0.4-1

will have to be rebuilt to link against OpenEXR 1.2.1. Currently, the
above packages were built against 1.1.1 which did not ship with a
SONAME. In fact, it was only days later that OpenEXR upstream informed
me that 1.1.1 was in fact a development release that should have never
been uploaded into Debian unstable as the new EXR file format hadn't
been finalised yet.

As such, OpenEXR now has a SONAME of 2 and the libopenexr0 package has
now been renamed to libopenexr2. Unfortunately, libopenexr2 is now set
to replace and conflict with libopenexr0 due to file name clashes.

I'm still looking for a sponsor to upload OpenEXR 1.2.1 into unstable
before the last day to upload low priority packages into unstable for
the Sarge freeze takes effect. Feel free to sponsor it yourself if it
hasn't been yet by the time you read this (a request has already been
made to the debian-devel list).

In the meantime, if you want to rebuild your packages against
libopenexr2 now, then you can download it from:


Good luck making the cutoff, and I apologise for any inconvenience

Andrew "Netsnipe" Lau

	Andrew "Netsnipe" Lau	<http://www.cse.unsw.edu.au/~alau/>
 Debian GNU/Linux Maintainer & UNSW Computing Students' Society President
		  "Nobody expects the Debian Inquisition!
     Our two weapons are fear and surprise...and ruthless efficiency!"

Attachment: signature.asc
Description: Digital signature

Reply to: