[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

UDD: proposed schema changes.



Hi,

I'd like to make some minor changes the current udd schema:
- Make severity an enum instead of text:
  CREATE TYPE bugs_severity AS ENUM ('fixed', 'wishlist', 'minor', 'normal', 'important', 'serious', 'grave', 'critical');
  This would allow to make queries using something like
  severity >= 'serious', and get what you expect, instead of a string
  compare.
- Add an affects_experimental in bugs and archived_bugs
- Rename affects_sarchived_table to affects_stable and
  affects_unsarchived_table to affects_unstable in
  archived_bugs.

Does anybody have any probems with those?


Kurt


Reply to: