[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

List of bugs that *must* be fixed before releasing Slink

The following bug reports *must* be fixed before the current frozen Debian
distribution can progress further in its development cycle.  Reminders have
been sent to the maintainers of these packages but some of the packages with
older bugs could probably use some assistance.

Package Name      Bug #  Bug Description [days old] (maintainer)
~~~~~~~~~~~~~~~~  ~~~~~  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
boot-floppies     31099  the 'load modules' screen hangs [19]  (Enrique Zanardi <debian-boot@lists.debian.org>)
boot-floppies     31618  Frozen boot floppies don't work on Tosh laptop. [0]  (Enrique Zanardi <debian-boot@lists.debian.org>)
dpkg              17624  dpkg: installs regular dir when .deb contains symlink ! [350]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg              21182  dpkg: dpkg can go into an infinite loop with --force-configure-any [274]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg              28519  dpkg: dpkg creates circular symlinks [80]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg              28817  dpkg takes no care over libdpkg [73]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg              30090  weirdass dpkg coredumps and xbase upgrade insanity [47]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg              30891  dpkg: Patch for update-alternatives to fix jdk problems [26]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg              31620  dpkg: don't use hard coded ENOENT [0]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg-dev          25537  dpkg-dev: dpkg-genchanges does not allow &quot;-&quot; in the architecture [159]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
dpkg-dev          31508  parsechangelog broken? [9]  (Klee Dienes and Ian Jackson <dpkg-maint@chiark.greenend.org.uk>)
fileutils         30184  fileutils: chown broken on symlinks [45]  (Galen Hazelwood <galenh@micron.net>)
fileutils         31717  fileutils: 'mv regularfile symlink' problems [0]  (Galen Hazelwood <galenh@micron.net>)
ftape-util        31825  Wrong path in modutils/ftape-util [0]  (Christian Meder <meder@isr.uni-stuttgart.de>)
ftp.debian.org    31282  upgrade-1386 directory in Incoming [16]  (Guy Maor <ftpmaster@debian.org>)
ftp.debian.org    31578  cfengine needs to be in frozen [0]  (Guy Maor <ftpmaster@debian.org>)
ftp.debian.org    31828  cgiwrap is old and unmaintained [0]  (Guy Maor <ftpmaster@debian.org>)
ftpwatch          31627  ftpwatch: trivial root exploit [0]  (Hakan Ardo <hakan@debian.org>)
general           30852  X packages do not upgrade automatically due to name change. [27]  (debian-devel@lists.debian.org)
kernel-image-2.0  31516  kernel-image-2.0.36: please add these ISDN fixes [8]  (Herbert Xu <herbert@debian.org>)
libc6             31734  severe bug in frozen base [0]  (Joel Klecker <glibc-maint@debian.org>)
libgd1g           31586  libgd1g: broken shlibs and wrong section in control file [7]  (Dermot Bradley <bradley@debian.org>)
licq              31614  licq: licq reads from the console when started from the menus! [0]  (Zed Pobre <zed@debian.org>)
lprng             31672  lprng: Allows printing from any remote by default! [0]  (Sven Rudolph <sr1@inf.tu-dresden.de>)
lprng             31889  lprng: error in postinst [0]  (Sven Rudolph <sr1@inf.tu-dresden.de>)
lynx              31200  lynx: Lynx should depend on net/mime-support (/etc/mailcap). [19]  (Christian Hudon <chrish@debian.org>)
mailtools         31786  perl regexp code hangs [0]  (Michael Alan Dorman <mdorman@debian.org>)
makepasswd        31059  makepasswd: --clear=PASS can be seen with ps [20]  (Johnie Ingram <johnie@debian.org>)
netscape-base-40  30878  netscape-base-407: Security vulnerabilities in 4.07 [26]  (Adam Heath <adam.heath@usa.net>)
netscape3         31518  netscape3: needs to conflict with plugger [8]  (Brian White <bcwhite@pobox.com>)
nonus.debian.org  21423  Dpkg-ftp can't handle alternative distributions [269]  (Heiko Schlittermann <heiko@datom.de>)
nonus.debian.org  31326  Broken symlinks on nonus.debian.org [14]  (Heiko Schlittermann <heiko@datom.de>)
pilot-link        31806  pilot-link: Can't build from source [0]  (Dermot Bradley <bradley@debian.org>)
postgresql        31410  postgresql: postgresql-dump failure [11]  (Oliver Elphick <Oliver.Elphick@lfix.co.uk>)
qtscape           31565  qtscape depends on obsolete version of qt [0]  (Heiko Schlittermann <heiko@lotte.sax.de>)
scwm              31555  libguile4: hoses scwm (yet again) [8]  (Francesco Tapparo <f.tapparo@vi.nettuno.it>)
snd               30941  snd does not work with slink version of lesstif [24]  (Geiger Guenter <geiger@iem.mhsg.ac.at>)
tcsh              28959  meta keys in tcsh don't work anymore! [71]  (Luis Francisco Gonzalez <luisgh@debian.org>)
wu-ftpd-academ    30931  wu-ftpd-academ: Can't build from source! [25]  (Heiko Schlittermann <heiko@lotte.sax.de>)
wu-ftpd-academ    31334  anon ftp requires /lib/libnss_files.so.1 [14]  (Heiko Schlittermann <heiko@lotte.sax.de>)
xcircuit          31741  xcircuit: error in loading shared libraries [0]  (Dale Scheetz <dwarf@polaris.net>)
xdm               29360  xdm: Stopped X without warning/asking [63]  (Branden Robinson <branden@debian.org>)
xserver-common    29166  xserver-common: should depend or at least recommend properly ver'd xlib6g [67]  (Branden Robinson <branden@debian.org>)

The above are all the "critical", "grave", and "important" bug reports, both
"pending" and "forwarded", for packages currently in frozen.

If you would like to help speed the release of the next Debian distribution,
you are encouraged to take part in fixing these bugs.  More information about
them can be found on Debian's web page:  http://www.debian.org/Bugs/

These bugs can either be degraded below critical, grave, and important, or
they can be fixed in non-maintainer releases.

Alternatively, the package can be reverted to the version in the previous
release.  If this is done, _don't_ close the bug but rather downgrade the
severity of the bug to "normal".

If there is a bug that you think must be fixed before the release of this
distribution, please upgrade its severity to critical, grave, or important.
For more info on this, see:  http://www.us.debian.org/Bugs/server-control.html
Be sure to cc the bug directly with the reason why the severity was changed.

                                 ( bcwhite@debian.org )

Debian GNU/Linux!  Search it at  http://insite.verisim.com/search/debian/simple

Reply to: