[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#729335: nvi: /etc/mailcap entries

Package: nvi
Version: 1.81.6-10
Severity: wishlist
Tags: patch

It'd be good if nvi was in /etc/mailcap the same way that vim is.
debian/nvi.mime and rules diff below can install
/usr/lib/mime/packages/nvi which mime-support "update-mime"
automatically puts into /etc/mailcap.

These bits are lower priority than vim as noted in the comments, but of
course you might remove vim in favour of nvi or the sysadmin can always
fiddle with /etc/mailcap.order or a user copy particular mailcap lines
for personal preference.

# priority=3 and priority=0 are below "more" at priority=5 and
# priority=1 in /usr/lib/mime/packages/util-linux, since believe
# "more" is easier to use than nview.
# priority=3 is also below "vim" priority=4 in
# /usr/lib/mime/packages/vim-common but only because vim is ahead in
# "update-alternatives" priority 30 vs nvi priority 20.

text/plain; nview '%s'; edit=nvi '%s'; compose=nvi '%s'; needsterminal; priority=3
text/*;     nview '%s'; edit=nvi '%s'; compose=nvi '%s'; needsterminal; priority=0
--- rules.orig	2013-11-12 08:45:36.000000000 +1100
+++ rules	2013-11-12 08:51:09.000000000 +1100
@@ -93,6 +93,7 @@
 	dh_installdocs -a
 	dh_installinit -a --init-script=nviboot -- start 70 S .
 	dh_installchangelogs -a Changes
+	dh_installmime
 	dh_lintian -a
 	dh_compress -a
 	dh_strip -a

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (990, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=en_AU.utf8, LC_CTYPE=en_AU.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages nvi depends on:
ii  libc6         2.17-93
ii  libdb5.1      5.1.29-7
ii  libncursesw5  5.9+20130608-1
ii  libtinfo5     5.9+20130608-1

Versions of packages nvi recommends:
pn  nvi-doc  <none>

nvi suggests no packages.

-- no debconf information

Reply to: