[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#363502: libreadline5: Something is wrong with binding keys to functions

On 19 May 2013 17:55, Vincent Lefevre <vincent@vinc17.net> wrote:
On 2013-05-19 14:17:59 +0100, Reuben Thomas wrote:
> This bug still exists, but I'm no longer sure to which package it should be
> assigned. I come across the bug in bash 4.2, which doesn't seem to depend
> on any version of libreadline now (e.g. bash 4.2-5).

It seems that bash now includes its own version of the GNU Readline
library. Perhaps the bug should be cloned...

The build dependency on readline for bash was removed here:

bash (2.05b-2-11) unstable; urgency=medium
  * Remove build dependency on readline (closes: #215165).
 -- Matthias Klose <doko@debian.org>  Tue, 14 Oct 2003 20:37:23 +0200

But you reported the bug in 2006. When you said "With readline 5.0
they work fine, but with 5.1 they don't work.", do you remember how
you tested that?

Yes, I had it working on readline 5.0, and when 5.1 was released, it no longer worked.
Anyway I can reproduce the Ctrl-u bug with pari-gp, which depends on
libreadline6 (note that this bug is still assigned to libreadline5).

libreadline5 seems to be used by few programs now, so it's not so important. I think it's most important that it be filed against libreadline6 and bash. However, since it's likely to be the same bug in libreadline5 and libreadline6, and also because it seems logical, maybe it should be cloned both to bash and libreadline6? Or assigned to libreadline6 and cloned to bash and libreadline5?

Reply to: