[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#707621: [hotswap] please build-depend on libxt-dev, libxext-dev, libxp-dev

Source: hotswap
User: openmotif@packages.debian.org
Usertags: lesstif2motif
Version: 0.4.0-12
Severity: normal
X-Debbugs-CC: openmotif@packages.debian.org

Hi Maintainer,

Your package build depends on libxt-dev, libxext-dev and libxp-dev but
does not declare this relation in the debian/control file. This is
currently not a problem as this is pulled in by the lesstif2-dev package
that you do depend on.

In the near future we like to replace lesstif2 in Debian with the
relicensed (open-)motif package. Lesstif2 was originally created as an
free alternative for motif, but in the meantime became unmaintained and
buggy. Motif itself is now free and got its latest maintenance release
last year.

To ease the transition that will happen sometime soon, we will follow
up on this, please explicitly build-depend on libxt-dev, libxext-dev,
and libxp-dev, as we don't intend to include these depends in libmotif-dev.

Kind regards,
Paul & Graham.

-- System Information:
Debian Release: 7.0
  APT prefers stable
  APT policy: (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: