[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#707340: please support python3 (and python3.3-uno)

Package: docvert-libreoffice
Version: 4.0-7
Severity: wishlist
Tags: upstream


LibreOffice 4.0 switched to python 3.3 as its (internal) python[1] and the
LibreOffice 4.x packages in Debian thus build a pyUNO variant for that
per default (python3.3-uno until python 3.3 - yes, really, >= 3.3 is
needed - is default at which time it will become python3-uno again).

While I keep a python-uno for compatibility and smooth transition[2]
building against python 2 will only be supported "for a few releases"
upstream. But upstream does NOT ship python 2 support.

If your upstream wants to support LibreOffice >= 4.0.0 (s)he does need
to adapt to python 3.3. Possibly even makng it work for both[2], but >= 3.3
is a must.

Please adapt (or make your upstream adapt, as said above they need to do
it anyway) for python3.



[1] https://wiki.documentfoundation.org/ReleaseNotes/4.0#Python
[2] And it's cumbersome, it needs various hacks like a nasty
    "copy pyuno, patch it to have different lib names, create symlink farm"
    and some tests even don't run with python2 anymore in 4.1.x
[3] as did LibreOffice itself, all LibreOffice packages have a
    python3.3-uno | python3-uno (>= 4.0) | python-uno depends

-- System Information:
Debian Release: 7.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages docvert-libreoffice depends on:
ii  adduser             3.113+nmu3
pn  docvert             <none>
ii  libreoffice-core    1:4.1.0~alpha1~git20130424-1
ii  libreoffice-writer  1:4.1.0~alpha1~git20130424-1
ii  lsb-base            4.1+Debian9
pn  pdf2svg             <none>
ii  procps              1:3.3.4-2
ii  python              2.7.3-4
ii  python-uno          1:4.1.0~alpha1~git20130424-1

docvert-libreoffice recommends no packages.

docvert-libreoffice suggests no packages.

Reply to: