[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#666838: Apache2.4 transition: reboot

Dear maintainers,

now that the work is done and Debian 7.0 (Wheezy) is released [*], we
are booting the Apache 2.4 transition process again. If you did not
already, please subscribe to transition bug #661958 to keep up with our
transition plan in detail as this IS going to affect your package.

Unless the Release Team is going to assign us another slot to start the
transition we are going to upload Apache 2.4 to Debian Sid at some point
in June. If you do not prepare a package which works together with the
Apache 2.4 server ABI by then, it is going to stop working at that time.

Let me emphasize again you do need to make adjustments in the
source of your package to get it working with Apache 2.4. Moreover, the
APIs slightly changed from 2.2 to 2.4 so that some modules may require
some porting. On the upside, it has been over a year that Apache 2.4 was
released and many upstreams made compatible releases. Moreover, porting
is easy in most cases and I've filed patches to some of your modules.

Either way, if you are trying to load existing module from Sid into
an Apache 2.4 web server is going to fail at runtime which renders your
package virtually useless.

We are planning to make the transition as smooth as possible to our
users. Thus, we do not want to let the Apache 2.4 package migrate to
Testing anytime soon. Instead, we'd like to let it migrate together with
a bunch of transitioned third party modules (i.e. your packages). Please
help us to make this happen soon.

While we invite everyone to provide updated packages as soon as
possible, don't hesitate to contact us if you feel like, we should wait
for you and your package when considering a migration to Debian Testing.
All packages which are not yet transitioned at that point will
eventually be removed from Testing.

Please prepare updates for your packages NOW and upload an upgraded
package to Debian Experimental and/or have a patch ready in your VCS. In
the case of the latter, please tag this bug pending. We chose some very
important external modules to be a blocker for our upload to Unstable.
That is, we will wait for you until we are uploading to Unstable, so
that we can do a coordinated upload to mitigate the impact of Sid users.
 If you are the maintainer of such a blocker module, we'll contact you
separately again. If you feel like you should be on the blocker list
denoted in #661958 please let us know as soon as possible.

[*] yah, it's not yet formally speaking

with kind regards,
Arno Töll
IRC: daemonkeeper on Freenode/OFTC
GnuPG Key-ID: 0x9D80F36D

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: