[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#701421: marked as done (zile: ftbfs with eglibc-2.17)

Your message dated Sun, 21 Apr 2013 23:32:50 +0000
with message-id <E1UU3kY-0007B8-8Y@franck.debian.org>
and subject line Bug#701421: fixed in zile 2.4.9-1
has caused the Debian Bug report #701421,
regarding zile: ftbfs with eglibc-2.17
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

701421: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=701421
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: src:zile
Version: 2.3.21-1
Severity: important
Tags: sid jessie
User: debian-glibc@lists.debian.org
Usertags: ftbfs-glibc-2.17

The package fails to build in a test rebuild on at least amd64 with
eglibc-2.17, but succeeds to build with eglibc-2.13. The
severity of this report may be raised before the jessie release.

The test rebuild was done together with GCC-4.8, so some issues
might be caused by the updated GCC as well.

  ./stdio.h:464:1: error: 'gets' undeclared here (not in a function)

The full build log can be found at:
The last lines of the build log are at the end of this report.

To install eglibc from experimental,

  apt-get -t experimental install libc6-dev

To build with GCC 4.8, either set CC=gcc-4.8 CXX=g++-4.8 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t experimental install g++ g++-4.7 g++-4.8 libc6-dev

	      < ./wctype.in.h; \
	} > wctype.h-t && \
	mv wctype.h-t wctype.h
/usr/bin/make  all-recursive
make[4]: Entering directory `/«PKGBUILDDIR»/lib'
make[5]: Entering directory `/«PKGBUILDDIR»/lib'
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..     -Wall -g -O2 -W -Wmissing-prototypes -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -MT gl_array_list.o -MD -MP -MF .deps/gl_array_list.Tpo -c -o gl_array_list.o gl_array_list.c
gl_array_list.c: In function 'gl_array_iterator_free':
gl_array_list.c:515:45: warning: unused parameter 'iterator' [-Wunused-parameter]
 gl_array_iterator_free (gl_list_iterator_t *iterator)
mv -f .deps/gl_array_list.Tpo .deps/gl_array_list.Po
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..     -Wall -g -O2 -W -Wmissing-prototypes -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -MT close-hook.o -MD -MP -MF .deps/close-hook.Tpo -c -o close-hook.o close-hook.c
mv -f .deps/close-hook.Tpo .deps/close-hook.Po
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..     -Wall -g -O2 -W -Wmissing-prototypes -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -MT exitfail.o -MD -MP -MF .deps/exitfail.Tpo -c -o exitfail.o exitfail.c
mv -f .deps/exitfail.Tpo .deps/exitfail.Po
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..     -Wall -g -O2 -W -Wmissing-prototypes -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -MT gl_linked_list.o -MD -MP -MF .deps/gl_linked_list.Tpo -c -o gl_linked_list.o gl_linked_list.c
In file included from gl_linked_list.c:29:0:
gl_anylinked_list2.h: In function 'gl_linked_node_value':
gl_anylinked_list2.h:173:33: warning: unused parameter 'list' [-Wunused-parameter]
 gl_linked_node_value (gl_list_t list, gl_list_node_t node)
gl_anylinked_list2.h: In function 'gl_linked_node_nx_set_value':
gl_anylinked_list2.h:179:40: warning: unused parameter 'list' [-Wunused-parameter]
 gl_linked_node_nx_set_value (gl_list_t list, gl_list_node_t node,
gl_anylinked_list2.h: In function 'gl_linked_iterator_free':
gl_anylinked_list2.h:1024:46: warning: unused parameter 'iterator' [-Wunused-parameter]
 gl_linked_iterator_free (gl_list_iterator_t *iterator)
mv -f .deps/gl_linked_list.Tpo .deps/gl_linked_list.Po
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..     -Wall -g -O2 -W -Wmissing-prototypes -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -MT gl_list.o -MD -MP -MF .deps/gl_list.Tpo -c -o gl_list.o gl_list.c
mv -f .deps/gl_list.Tpo .deps/gl_list.Po
gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..     -Wall -g -O2 -W -Wmissing-prototypes -Wstrict-prototypes -D_FORTIFY_SOURCE=2 -MT localcharset.o -MD -MP -MF .deps/localcharset.Tpo -c -o localcharset.o localcharset.c
In file included from localcharset.c:26:0:
./stdio.h:464:1: error: 'gets' undeclared here (not in a function)
 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
make[5]: *** [localcharset.o] Error 1
make[5]: Leaving directory `/«PKGBUILDDIR»/lib'
make[4]: *** [all-recursive] Error 1
make[3]: *** [all] Error 2
make[4]: Leaving directory `/«PKGBUILDDIR»/lib'
make[3]: Leaving directory `/«PKGBUILDDIR»/lib'
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make: *** [build-stamp] Error 2
make[2]: Leaving directory `/«PKGBUILDDIR»'
make[1]: Leaving directory `/«PKGBUILDDIR»'
dpkg-buildpackage: error: debian/rules build gave error exit status 2

--- End Message ---
--- Begin Message ---
Source: zile
Source-Version: 2.4.9-1

We believe that the bug you reported is fixed in the latest version of
zile, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 701421@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Axel Beckert <abe@debian.org> (supplier of updated zile package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 22 Apr 2013 01:10:58 +0200
Source: zile
Binary: zile
Architecture: source amd64
Version: 2.4.9-1
Distribution: experimental
Urgency: low
Maintainer: Axel Beckert <abe@debian.org>
Changed-By: Axel Beckert <abe@debian.org>
 zile       - very small Emacs-subset editor
Closes: 691481 701421 705816
 zile (2.4.9-1) experimental; urgency=low
   * New upstream release
     + Fixes FTBFS with eglibc-2.17 (Closes: #701421)
     + Add new build-dependency on libgc-dev
     + Installs dotzile.sample in docdir (Closes: #691481)
   * Adopt the package. (Closes: #705816) Thanks for your work, Nicolas!
     + Update debian/copyright.
   * Bump Standards-Version to 3.9.4 (no changes)
   * Bump debhelper-compatibility to 9 and switch to dh7 style debian/rules:
     + Update version build-dependency on debhelper.
     + Switch to using dh_auto_{configure,build,install,clean}
     + Switch from inline file lists to debian/{docs,clean} file lists
     + Finally switch the normalized debian/rules to dh7 style
   * No more remove *-stamp files manually (done by dh_clean already)
   * Add tests/interactive/mark-word.input-emacs and config.log to
     debian/clean as they're occassionally left over.
   * Ignore modified zile.1.in files in diff.
   * Run test suite at build time
     + Pipe its output through "cat -v" to prevent binary garbage in the
       log or on the terminal.
     + Pass --without-emacs to configure to prevent also running the test
       suite against installed Emacsen.
   * Switch to source format "3.0 (quilt)".
   * Add Vcs-* headers
   * Remove files .topdeps and .topmsg from source package which sneaked in
     with 2.3.12-1.
   * Fix the following lintian warnings:
     + debian-rules-missing-recommended-target
     + copyright-refers-to-symlink-license
 c8624914bdfc49c67f53b87fbcdb82d25247b7b2 1194 zile_2.4.9-1.dsc
 f233487e2d0ce99d7670832d106d1a2503d4c925 1192776 zile_2.4.9.orig.tar.gz
 496ffe270441fa99d6649ad8191253d404ba44ac 8609 zile_2.4.9-1.debian.tar.gz
 aced2d1e810a86fc9aabb58c2fbd3dc75fa19f49 183924 zile_2.4.9-1_amd64.deb
 17db051f13b109e25e1c6cb361aff371fcfe2a7c07f0068a2f8876967f6062f4 1194 zile_2.4.9-1.dsc
 c71959c7aca02ac66be526ecccbc7954fb0ea7591ed3c13311a95e8f040b0049 1192776 zile_2.4.9.orig.tar.gz
 7a0ec9326b9fef9982db53fdfe5ed6042b0646f73af838d72a182ae21695f8ef 8609 zile_2.4.9-1.debian.tar.gz
 3cf1930c28bcfbda37d80cc31cdd0a2829893e21a7206a4f2d21234aecd3458c 183924 zile_2.4.9-1_amd64.deb
 e76e85462eea2bfdccb6a8d90e999355 1194 editors optional zile_2.4.9-1.dsc
 84a0af58fb4fbe3af16bde2ef2b8f5ae 1192776 editors optional zile_2.4.9.orig.tar.gz
 e4ea2a4c4b20edc2c104cdcc3c8a9894 8609 editors optional zile_2.4.9-1.debian.tar.gz
 a90a1859fb7c0af07641b543b22b1b9d 183924 editors optional zile_2.4.9-1_amd64.deb

Version: GnuPG v1.4.12 (GNU/Linux)


--- End Message ---

Reply to: