[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#700896: cinnamon doesn't show up in wdm's window/session manager list

Package: cinnamon,wdm
Version: cinnamon/1.6.7-2
Version: wdm/1.28-13

Dear Cinnamon Maintainers, dear QA Team,

I'm using wdm as display manager. While XFCE, LXDE and GNOME show up
in wdm's list of available window and session managers, Cinnamon

This means that I cannot choose to run Cinnamon when using wdm as
display manager. I'd have expected that Cinnamon shows up in wdm's
list as all other installed window and session managers seem to do.

It doesn't make a difference if I use wdm from Wheezy/Sid (1.28-13) or
from Experimental (1.28-14~exp1).

I'm reporting this issue against cinnamon and wdm since I don't know
which of these packages are the source for this issue. And because
fixing this issue in one of the two packages should already suffice.

-- System Information:
Debian Release: 7.0
  APT prefers unstable
  APT policy: (990, 'unstable'), (900, 'testing'), (600, 'stable'), (200, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.7-trunk-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cinnamon depends on:
ii  cinnamon-common                              1.6.7-2
ii  dconf-gsettings-backend [gsettings-backend]  0.12.1-3
ii  gconf2                                       3.2.5-1+build1
ii  gir1.2-accountsservice-1.0                   0.6.21-8
ii  gir1.2-atk-1.0                               2.4.0-2
ii  gir1.2-clutter-1.0                           1.10.8-2
ii  gir1.2-cogl-1.0                              1.10.2-6
ii  gir1.2-coglpango-1.0                         1.10.2-6
ii  gir1.2-freedesktop                           1.32.1-1
ii  gir1.2-gconf-2.0                             3.2.5-1+build1
ii  gir1.2-gdesktopenums-3.0                     3.4.2-3
ii  gir1.2-gdkpixbuf-2.0                         2.26.1-1
ii  gir1.2-gkbd-3.0                    
ii  gir1.2-glib-2.0                              1.32.1-1
ii  gir1.2-gmenu-3.0                             3.4.2-7
ii  gir1.2-gnomebluetooth-1.0                    3.4.2-1
ii  gir1.2-gtk-3.0                               3.4.2-6
ii  gir1.2-json-1.0                              0.14.2-1
ii  gir1.2-muffin-3.0                            1.1.2-1
ii  gir1.2-networkmanager-1.0          
ii  gir1.2-pango-1.0                             1.30.0-1
ii  gir1.2-polkit-1.0                            0.105-3
ii  gir1.2-soup-2.4                              2.38.1-2
ii  gir1.2-upowerglib-1.0                        0.9.17-1
ii  gjs                                          1.32.0-5
ii  gkbd-capplet                       
ii  gnome-icon-theme-symbolic                    3.4.0-2
ii  gnome-session-bin                  
ii  gnome-settings-daemon                        3.4.2+git20121218.7c1322-3
ii  gsettings-desktop-schemas                    3.4.2-3
ii  libatk1.0-0                                  2.4.0-2
ii  libc6                                        2.13-38
ii  libcairo2                                    1.12.2-3
ii  libcanberra0                                 0.28-6
ii  libclutter-1.0-0                             1.10.8-2
ii  libcogl-pango0                               1.10.2-6
ii  libcogl9                                     1.10.2-6
ii  libcroco3                                    0.6.6-2
ii  libdbus-glib-1-2                             0.100.1-1
ii  libgdk-pixbuf2.0-0                           2.26.1-1
ii  libgirepository-1.0-1                        1.32.1-1
ii  libgjs0b [libgjs0-libmozjs185-1.0]           1.32.0-5
ii  libgl1-mesa-glx [libgl1]                     8.0.5-3
ii  libglib2.0-0                                 2.33.12+really2.32.4-5
ii  libgnome-desktop-3-2                         3.4.2-1
ii  libgnome-keyring0                            3.4.1-1
ii  libgnome-menu-3-0                            3.4.2-7
ii  libgstreamer0.10-0                           0.10.36-1.1
ii  libgtk-3-0                                   3.4.2-6
ii  libjson-glib-1.0-0                           0.14.2-1
ii  libmozjs185-1.0                              1.8.5-1.0.0+dfsg-4
ii  libmuffin0                                   1.1.2-1
ii  libnm-glib4                        
ii  libnm-util2                        
ii  libpango1.0-0                                1.30.0-1
ii  libpolkit-agent-1-0                          0.105-3
ii  libpolkit-gobject-1-0                        0.105-3
ii  libpulse-mainloop-glib0                      2.0-6
ii  libpulse0                                    2.0-6
ii  libstartup-notification0                     0.12-1
ii  libx11-6                                     2:1.5.0-1
ii  libxfixes3                                   1:5.0-4
ii  libxml2                                      2.8.0+dfsg1-7
ii  mesa-utils                                   8.0.1-2+b3
ii  multiarch-support                            2.13-38
ii  python                                       2.7.3-4
ii  python-dbus                                  1.1.1-1
ii  python-gconf                                 2.28.1+dfsg-1
ii  python-imaging                               1.1.7-4
ii  python-lxml                                  2.3.5-1

Versions of packages cinnamon recommends:
ii  gnome-control-center  1:

cinnamon suggests no packages.

-- no debconf information

Reply to: