[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Please check PHP 5.4 compatibility in your package(s)

Dear Debian QA Group,

as you might have read in the debian-devel-announce, we are preparing
PHP 5.4 to enter unstable.  As you maintain package(s) using PHP, it
would greatly help us (the Debian PHP maintainers) if you can test
compatibility of your package(s) with PHP 5.4 which is currently in
the experimental suite.  After testing please report success (or
failures which obviously will need fixing) to the wiki page we have
prepared for tracking the transition:


List of packages maintained by you:


To test your package with PHP 5.4 from experimental you need to add

  deb http://ftp.cz.debian.org/debian experimental main

to your /etc/apt/sources.lists and add

  Package: php5*
  Pin: release n=experimental
  Pin-Priority: 500

  Package: libapache2-mod-php5*
  Pin: release n=experimental
  Pin-Priority: 500

  Package: php-pear
  Pin: release n=experimental
  Pin-Priority: 500

to your /etc/apt/preferences file.

Note: Some of you already might know that there are some bugs related
      to PHP 5.4, because there is a open bug.  In that case I am
      sorry that I am mailing you again, but I thought it would be
      good if you were informed about the wiki page, where you can
      report the status of whole package and not just FTBFS or PHP
      Lint errors.

Ondrej Sury <ondrej@debian.org>

Reply to: