[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#648043: marked as done (Too strict dependencies on binutils, maybe due to inappropriate dynamic linking with binutils libraries?)

Your message dated Wed, 09 Nov 2011 07:47:21 +0000
with message-id <E1RO2sT-0004kV-LN@franck.debian.org>
and subject line Bug#648043: fixed in nitpic 0.1-13
has caused the Debian Bug report #648043,
regarding Too strict dependencies on binutils, maybe due to inappropriate dynamic linking with binutils libraries?
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

648043: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648043
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: nitpic
Version: 0.1-12

The nitpic package seems to depend on a very particular version of

# info: nitpic depends on binutils << (ok, testing has
# info: nitpic depends on binutils >= (ok, testing
  has version

hence blocking migration of newer binutils to testing ("Updating
binutils makes 2 non-depending packages uninstallable on i386: lush,
nitpic", see
http://release.debian.org/migration/testing.pl?package=binutils), and
also blocking anything which depends on newer binutils, e.g., version
3.0.0-6 of the linux-2.6 package.

I suspect the dependencies are put in automagically because of
dynamically (rather than statically) linking to one or both of libbfd
and libopcodes. Which is a bad thing to do, as explained in the thread

I have already filed a similar bug report on the other package, lush,
which blocks binutils in a similar way, see

/Niels Möller

Niels Möller. PGP-encrypted email is preferred. Keyid C0B98E26.
Internet email is subject to wholesale government surveillance.

--- End Message ---
--- Begin Message ---
Source: nitpic
Source-Version: 0.1-13

We believe that the bug you reported is fixed in the latest version of
nitpic, which is due to be installed in the Debian FTP archive:

  to main/n/nitpic/nitpic_0.1-13.diff.gz
  to main/n/nitpic/nitpic_0.1-13.dsc
  to main/n/nitpic/nitpic_0.1-13_amd64.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 648043@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Magnus Holmgren <holmgren@debian.org> (supplier of updated nitpic package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA256

Format: 1.8
Date: Tue, 08 Nov 2011 18:32:40 +0100
Source: nitpic
Binary: nitpic
Architecture: source amd64
Version: 0.1-13
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Magnus Holmgren <holmgren@debian.org>
 nitpic     - simulator for the Microchip PIC16C84 microcontroller
Closes: 648043
 nitpic (0.1-13) unstable; urgency=low
   * QA upload.
   * Link statically against binutils libraries (Closes: #648043). As a
     consequence, we also need to link against zlib.
   * Drop ancient prerm script from /usr/doc transition.
   * Add build-indep and build-arch targets to debian/rules.
 6208d7f98c152449aca7438afcf60735f30935a5 1044 nitpic_0.1-13.dsc
 d9bdd1cebed663f8865fcd7f722bace1306374ab 10675 nitpic_0.1-13.diff.gz
 a114721e327e552a28e1d428d926bbff1ca2d97a 402446 nitpic_0.1-13_amd64.deb
 f65ca3d6606cd604e65eea81189deaca49da56b0a97b8672bdc89095452f5593 1044 nitpic_0.1-13.dsc
 aa7d0a8856cbc8b13fc35274780739066b0ccca7a1d04bd47c2c659ae973f514 10675 nitpic_0.1-13.diff.gz
 cf7db90ad50b466c0e1a6ddb7caca0cd259ca24a1e3a51bd168dd958ce72b1dc 402446 nitpic_0.1-13_amd64.deb
 e9cb05326a6e7a8b14feede68b7a8454 1044 electronics extra nitpic_0.1-13.dsc
 a5711508b6fcb14ef5c1740acf415f62 10675 electronics extra nitpic_0.1-13.diff.gz
 25b55602ddeae06a46284fc18dfb8939 402446 electronics extra nitpic_0.1-13_amd64.deb

Version: GnuPG v1.4.11 (GNU/Linux)


--- End Message ---

Reply to: