[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#645565: needs porting to the new libpanel-applet interface

Source: ddccontrol
Version: 0.4.2-9
Severity: serious
User: pkg-gnome-maintainers@lists.alioth.debian.org
Usertags: applets-transition


this package currently depends on libpanel-applet2-0 - most likely 
because it provides an applet for the GNOME panel.

The introduction of gnome-panel 3.0 to unstable is imminent. In this 
version, the libpanel-applet library has undergone large changes, and 
file-browser-applet requires changes to support this version:
 * updating to the D-Bus activation mechanism
 * porting to GTK+ 3

You might want to check if upstream developers provide a new version, 
compatible with gnome-panel 3.x. Otherwise, porting is a feasible task 
if you have a pair of hours to spare. If you feel like it, the 
following guides should help you:
 * http://developer.gnome.org/gtk3/stable/gtk-migrating-2-to-3.html
 * http://live.gnome.org/GnomeGoals/AppletsDbusMigration

For packages that provide other functionality than the GNOME applet, 
you can simply disable it in the build and remove the 
build-dependency if it hasn’t been ported. 

For pure applets packages, you should ask for removal from the 
archive if you do not intend to port it to the new interface. Such 
packages that have not been ported when gnome-panel is ready to 
migrate will be kicked out of testing.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.0.0-2-486
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: