[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#643206: loop-aes-utils: FTBFS: dpkg-buildpackage: error: dpkg-source -b loop-aes-utils-2.16.2 gave error exit status 2

Source: loop-aes-utils
Version: 2.16.2-2
Severity: important
Tags: wheezy sid
User: debian-qa@lists.debian.org
Usertags: qa-ftbfs-20110923 qa-ftbfs
Justification: FTBFS on amd64


During a rebuild of all packages in sid, your package failed to build on

Relevant part:
>  fakeroot debian/rules clean
> dh_testdir
> dh_testroot
> rm -f *-stamp
> rm -rf debian/build-deb debian/build-udeb
> [ ! -f Makefile ] || /usr/bin/make distclean
> dh_clean 
>  dpkg-source -b loop-aes-utils-2.16.2
> dpkg-source: info: using source format `3.0 (quilt)'
> dpkg-source: info: building loop-aes-utils using existing ./loop-aes-utils_2.16.2.orig.tar.gz
> dpkg-source: info: local changes detected, the modified files are:
>  loop-aes-utils-2.16.2/config.guess
>  loop-aes-utils-2.16.2/config.sub
> dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/loop-aes-utils_2.16.2-2.diff.5i7xJO
> dpkg-source: info: you can integrate the local changes with dpkg-source --commit
> dpkg-buildpackage: error: dpkg-source -b loop-aes-utils-2.16.2 gave error exit status 2
> ────────────────────────────────────────────────────────────────────────────────
> Build finished at 20110924-0011

The full build log is available from:

This error is due to recent dpkg changes "“dpkg-source -b” on a “2.0”
or “3.0 (quilt)” source package will fail if it detects upstream changes
which are not managed by a quilt patch." [0] 

[0] http://lists.debian.org/debian-devel-announce/2011/09/msg00001.html

A list of current common problems and possible solutions is available at 
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
of the Grid'5000 platform, using a clean chroot.  Internet was not
accessible from the build systems.

Reply to: