[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#627350: marked as done (python-camelot: ships Python module "example")



Your message dated Fri, 23 Sep 2011 19:34:31 +0000
with message-id <E1R7BW3-0006PC-8R@franck.debian.org>
and subject line Bug#642406: Removed package(s) from unstable
has caused the Debian Bug report #627350,
regarding python-camelot: ships Python module "example"
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
627350: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=627350
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: python-camelot,python-django-authority
Version: python-camelot/11.05.13-c1-1
Version: python-django-authority/0.4-1
Severity: serious
User: treinen@debian.org
Usertags: edos-file-overwrite

Date: 2011-05-19
Architecture: amd64
Distribution: sid

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:


WARNING: The following packages cannot be authenticated!
  libcap2 libpcre3 libwrap0 libxml2 mime-support python2.6-minimal libdb4.8
  libexpat1 python2.6 python-minimal python python-central python-support ucf
  libfreetype6 ttf-dejavu-core fontconfig-config libfontconfig1 fontconfig
  hicolor-icon-theme iso-codes libasound2 libasyncns0 libxau6 x11-common
  libice6 libsm6 libxdmcp6 libxcb1 libx11-data libx11-6 libxt6 libaudio2
  libdbus-1-3 libdrm2 libogg0 libflac8 libxfixes3 libxdamage1 libxext6
  libxxf86vm1 libgl1-mesa-glx libglib2.0-0 libglu1-mesa libgstreamer0.10-0
  libgstreamer-plugins-base0.10-0 libjpeg62 libjs-jquery liblcms1 libmng1
  libpng12-0 libvorbis0a libvorbisenc2 libsndfile1 libxi6 libxtst6 libpulse0
  libpython2.6 libqtcore4 libqt4-xml libqt4-dbus libqt4-network libqt4-script
  libqt4-sql libqt4-xmlpatterns libtiff4 libxrender1 libqtgui4
  libqt4-declarative libqt4-designer libqt4-help libqt4-opengl
  libqt4-scripttools libqt4-svg libqt4-test libqtassistantclient4
  libqtlocation1 libxv1 libqtmultimediakit1 libqtwebkit4 python-antlr
  python-pkg-resources python-babel python-sqlalchemy python-elixir
  python-decorator python-tempita python-migrate python-markupsafe
  python-jinja2 python-chardet python-xlwt python-xlrd python-sip python-qt4
  python-pybabel python-jinja python-excelerator tango-icon-theme
  python-camelot python-django-authority

Extracting templates from packages: 29%
Extracting templates from packages: 59%
Extracting templates from packages: 89%
Extracting templates from packages: 100%
Preconfiguring packages ...
Authentication warning overridden.
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package libcap2.
(Reading database ... 9229 files and directories currently installed.)
Unpacking libcap2 (from .../libcap2_1%3a2.20-1_amd64.deb) ...
Selecting previously deselected package libpcre3.
Unpacking libpcre3 (from .../libpcre3_8.12-3_amd64.deb) ...
Selecting previously deselected package libwrap0.
Unpacking libwrap0 (from .../libwrap0_7.6.q-19_amd64.deb) ...
Selecting previously deselected package libxml2.
Unpacking libxml2 (from .../libxml2_2.7.8.dfsg-2+b1_amd64.deb) ...
Selecting previously deselected package mime-support.
Unpacking mime-support (from .../mime-support_3.51-1_all.deb) ...
Selecting previously deselected package python2.6-minimal.
Unpacking python2.6-minimal (from .../python2.6-minimal_2.6.6-10_amd64.deb) ...
Selecting previously deselected package libdb4.8.
Unpacking libdb4.8 (from .../libdb4.8_4.8.30-8_amd64.deb) ...
Selecting previously deselected package libexpat1.
Unpacking libexpat1 (from .../libexpat1_2.0.1-7_amd64.deb) ...
Selecting previously deselected package python2.6.
Unpacking python2.6 (from .../python2.6_2.6.6-10_amd64.deb) ...
Selecting previously deselected package python-minimal.
Unpacking python-minimal (from .../python-minimal_2.6.6-14_all.deb) ...
Selecting previously deselected package python.
Unpacking python (from .../python_2.6.6-14_all.deb) ...
Selecting previously deselected package python-central.
Unpacking python-central (from .../python-central_0.6.17_all.deb) ...
Selecting previously deselected package python-support.
Unpacking python-support (from .../python-support_1.0.13_all.deb) ...
Selecting previously deselected package ucf.
Unpacking ucf (from .../ucf_3.0025+nmu2_all.deb) ...
Moving old data out of the way
Selecting previously deselected package libfreetype6.
Unpacking libfreetype6 (from .../libfreetype6_2.4.4-1_amd64.deb) ...
Selecting previously deselected package ttf-dejavu-core.
Unpacking ttf-dejavu-core (from .../ttf-dejavu-core_2.33-1_all.deb) ...
Selecting previously deselected package fontconfig-config.
Unpacking fontconfig-config (from .../fontconfig-config_2.8.0-2.2_all.deb) ...
Selecting previously deselected package libfontconfig1.
Unpacking libfontconfig1 (from .../libfontconfig1_2.8.0-2.2_amd64.deb) ...
Selecting previously deselected package fontconfig.
Unpacking fontconfig (from .../fontconfig_2.8.0-2.2_amd64.deb) ...
Selecting previously deselected package hicolor-icon-theme.
Unpacking hicolor-icon-theme (from .../hicolor-icon-theme_0.12-1_all.deb) ...
Selecting previously deselected package iso-codes.
Unpacking iso-codes (from .../iso-codes_3.25.1-1_all.deb) ...
Selecting previously deselected package libasound2.
Unpacking libasound2 (from .../libasound2_1.0.23-4_amd64.deb) ...
Selecting previously deselected package libasyncns0.
Unpacking libasyncns0 (from .../libasyncns0_0.8-2_amd64.deb) ...
Selecting previously deselected package libxau6.
Unpacking libxau6 (from .../libxau6_1%3a1.0.6-1_amd64.deb) ...
Selecting previously deselected package x11-common.
Unpacking x11-common (from .../x11-common_1%3a7.6+6_all.deb) ...
Selecting previously deselected package libice6.
Unpacking libice6 (from .../libice6_2%3a1.0.7-1_amd64.deb) ...
Selecting previously deselected package libsm6.
Unpacking libsm6 (from .../libsm6_2%3a1.2.0-1_amd64.deb) ...
Selecting previously deselected package libxdmcp6.
Unpacking libxdmcp6 (from .../libxdmcp6_1%3a1.1.0-1_amd64.deb) ...
Selecting previously deselected package libxcb1.
Unpacking libxcb1 (from .../libxcb1_1.7-2_amd64.deb) ...
Selecting previously deselected package libx11-data.
Unpacking libx11-data (from .../libx11-data_2%3a1.4.3-1_all.deb) ...
Selecting previously deselected package libx11-6.
Unpacking libx11-6 (from .../libx11-6_2%3a1.4.3-1_amd64.deb) ...
Selecting previously deselected package libxt6.
Unpacking libxt6 (from .../libxt6_1%3a1.1.1-1_amd64.deb) ...
Selecting previously deselected package libaudio2.
Unpacking libaudio2 (from .../libaudio2_1.9.2-7_amd64.deb) ...
Selecting previously deselected package libdbus-1-3.
Unpacking libdbus-1-3 (from .../libdbus-1-3_1.4.8-3_amd64.deb) ...
Selecting previously deselected package libdrm2.
Unpacking libdrm2 (from .../libdrm2_2.4.25-2_amd64.deb) ...
Selecting previously deselected package libogg0.
Unpacking libogg0 (from .../libogg0_1.2.2~dfsg-1_amd64.deb) ...
Selecting previously deselected package libflac8.
Unpacking libflac8 (from .../libflac8_1.2.1-3_amd64.deb) ...
Selecting previously deselected package libxfixes3.
Unpacking libxfixes3 (from .../libxfixes3_1%3a5.0-2_amd64.deb) ...
Selecting previously deselected package libxdamage1.
Unpacking libxdamage1 (from .../libxdamage1_1%3a1.1.3-1_amd64.deb) ...
Selecting previously deselected package libxext6.
Unpacking libxext6 (from .../libxext6_2%3a1.3.0-1_amd64.deb) ...
Selecting previously deselected package libxxf86vm1.
Unpacking libxxf86vm1 (from .../libxxf86vm1_1%3a1.1.1-1_amd64.deb) ...
Selecting previously deselected package libgl1-mesa-glx.
Unpacking libgl1-mesa-glx (from .../libgl1-mesa-glx_7.10.2-2_amd64.deb) ...
Selecting previously deselected package libglib2.0-0.
Unpacking libglib2.0-0 (from .../libglib2.0-0_2.28.6-1_amd64.deb) ...
Selecting previously deselected package libglu1-mesa.
Unpacking libglu1-mesa (from .../libglu1-mesa_7.10.2-2_amd64.deb) ...
Selecting previously deselected package libgstreamer0.10-0.
Unpacking libgstreamer0.10-0 (from .../libgstreamer0.10-0_0.10.34-1_amd64.deb) ...
Selecting previously deselected package libgstreamer-plugins-base0.10-0.
Unpacking libgstreamer-plugins-base0.10-0 (from .../libgstreamer-plugins-base0.10-0_0.10.34-1_amd64.deb) ...
Selecting previously deselected package libjpeg62.
Unpacking libjpeg62 (from .../libjpeg62_6b1-1_amd64.deb) ...
Selecting previously deselected package libjs-jquery.
Unpacking libjs-jquery (from .../libjs-jquery_1.5.1-1_all.deb) ...
Selecting previously deselected package liblcms1.
Unpacking liblcms1 (from .../liblcms1_1.18.dfsg-1.2+b4_amd64.deb) ...
Selecting previously deselected package libmng1.
Unpacking libmng1 (from .../libmng1_1.0.10-1+b1_amd64.deb) ...
Selecting previously deselected package libpng12-0.
Unpacking libpng12-0 (from .../libpng12-0_1.2.44-2_amd64.deb) ...
Selecting previously deselected package libvorbis0a.
Unpacking libvorbis0a (from .../libvorbis0a_1.3.2-1_amd64.deb) ...
Selecting previously deselected package libvorbisenc2.
Unpacking libvorbisenc2 (from .../libvorbisenc2_1.3.2-1_amd64.deb) ...
Selecting previously deselected package libsndfile1.
Unpacking libsndfile1 (from .../libsndfile1_1.0.24-1_amd64.deb) ...
Selecting previously deselected package libxi6.
Unpacking libxi6 (from .../libxi6_2%3a1.4.2-1_amd64.deb) ...
Selecting previously deselected package libxtst6.
Unpacking libxtst6 (from .../libxtst6_2%3a1.2.0-1_amd64.deb) ...
Selecting previously deselected package libpulse0.
Unpacking libpulse0 (from .../libpulse0_0.9.21-4_amd64.deb) ...
Selecting previously deselected package libpython2.6.
Unpacking libpython2.6 (from .../libpython2.6_2.6.6-10_amd64.deb) ...
Selecting previously deselected package libqtcore4.
Unpacking libqtcore4 (from .../libqtcore4_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-xml.
Unpacking libqt4-xml (from .../libqt4-xml_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-dbus.
Unpacking libqt4-dbus (from .../libqt4-dbus_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-network.
Unpacking libqt4-network (from .../libqt4-network_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-script.
Unpacking libqt4-script (from .../libqt4-script_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-sql.
Unpacking libqt4-sql (from .../libqt4-sql_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-xmlpatterns.
Unpacking libqt4-xmlpatterns (from .../libqt4-xmlpatterns_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libtiff4.
Unpacking libtiff4 (from .../libtiff4_3.9.5-1_amd64.deb) ...
Selecting previously deselected package libxrender1.
Unpacking libxrender1 (from .../libxrender1_1%3a0.9.6-1_amd64.deb) ...
Selecting previously deselected package libqtgui4.
Unpacking libqtgui4 (from .../libqtgui4_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-declarative.
Unpacking libqt4-declarative (from .../libqt4-declarative_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-designer.
Unpacking libqt4-designer (from .../libqt4-designer_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-help.
Unpacking libqt4-help (from .../libqt4-help_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-opengl.
Unpacking libqt4-opengl (from .../libqt4-opengl_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-scripttools.
Unpacking libqt4-scripttools (from .../libqt4-scripttools_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-svg.
Unpacking libqt4-svg (from .../libqt4-svg_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqt4-test.
Unpacking libqt4-test (from .../libqt4-test_4%3a4.7.3-1_amd64.deb) ...
Selecting previously deselected package libqtassistantclient4.
Unpacking libqtassistantclient4 (from .../libqtassistantclient4_4.6.3-3_amd64.deb) ...
Selecting previously deselected package libqtlocation1.
Unpacking libqtlocation1 (from .../libqtlocation1_1.2.0~beta0+git3174-2_amd64.deb) ...
Selecting previously deselected package libxv1.
Unpacking libxv1 (from .../libxv1_2%3a1.0.6-1_amd64.deb) ...
Selecting previously deselected package libqtmultimediakit1.
Unpacking libqtmultimediakit1 (from .../libqtmultimediakit1_1.2.0~beta0+git3174-2_amd64.deb) ...
Selecting previously deselected package libqtwebkit4.
Unpacking libqtwebkit4 (from .../libqtwebkit4_2.1.0~2011week13-1_amd64.deb) ...
Selecting previously deselected package python-antlr.
Unpacking python-antlr (from .../python-antlr_2.7.7-16_all.deb) ...
Selecting previously deselected package python-pkg-resources.
Unpacking python-pkg-resources (from .../python-pkg-resources_0.6.15-2_all.deb) ...
Selecting previously deselected package python-babel.
Unpacking python-babel (from .../python-babel_0.9.6-1_all.deb) ...
Selecting previously deselected package python-sqlalchemy.
Unpacking python-sqlalchemy (from .../python-sqlalchemy_0.6.7-2_all.deb) ...
Selecting previously deselected package python-elixir.
Unpacking python-elixir (from .../python-elixir_0.7.1-1_all.deb) ...
Selecting previously deselected package python-decorator.
Unpacking python-decorator (from .../python-decorator_3.2.0-1_all.deb) ...
Selecting previously deselected package python-tempita.
Unpacking python-tempita (from .../python-tempita_0.4-1_all.deb) ...
Selecting previously deselected package python-migrate.
Unpacking python-migrate (from .../python-migrate_0.6.1-2_all.deb) ...
Selecting previously deselected package python-markupsafe.
Unpacking python-markupsafe (from .../python-markupsafe_0.12-2_amd64.deb) ...
Selecting previously deselected package python-jinja2.
Unpacking python-jinja2 (from .../python-jinja2_2.5.5-5_amd64.deb) ...
Selecting previously deselected package python-chardet.
Unpacking python-chardet (from .../python-chardet_2.0.1-1_all.deb) ...
Selecting previously deselected package python-xlwt.
Unpacking python-xlwt (from .../python-xlwt_0.7.2+debian1-2_all.deb) ...
Selecting previously deselected package python-xlrd.
Unpacking python-xlrd (from .../python-xlrd_0.6.1-2_all.deb) ...
Selecting previously deselected package python-sip.
Unpacking python-sip (from .../python-sip_4.12.1-1+b2_amd64.deb) ...
Selecting previously deselected package python-qt4.
Unpacking python-qt4 (from .../python-qt4_4.8.3-2+b1_amd64.deb) ...
Selecting previously deselected package python-pybabel.
Unpacking python-pybabel (from .../python-pybabel_0.9.6-1_all.deb) ...
Selecting previously deselected package python-jinja.
Unpacking python-jinja (from .../python-jinja_1.2-3+b2_amd64.deb) ...
Selecting previously deselected package python-excelerator.
Unpacking python-excelerator (from .../python-excelerator_0.6.4.1-1_all.deb) ...
Selecting previously deselected package tango-icon-theme.
Unpacking tango-icon-theme (from .../tango-icon-theme_0.8.90-3_all.deb) ...
Selecting previously deselected package python-camelot.
Unpacking python-camelot (from .../python-camelot_11.05.13-c1-1_all.deb) ...
Selecting previously deselected package python-django-authority.
Unpacking python-django-authority (from .../python-django-authority_0.4-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python-django-authority_0.4-1_all.deb (--unpack):
 trying to overwrite '/usr/share/pyshared/example/settings.py', which is also in package python-camelot 11.05.13-c1-1
configured to not write apport reports
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/python-django-authority_0.4-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

  /usr/share/pyshared/example/settings.py

This bug is assigned to both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package. You may
also register in the BTS that the other package is affected by the bug.

-Ralf.

PS: for more information about the detection of file overwrite errors
of this kind see http://edos.debian.net/file-overwrites/.



--- End Message ---
--- Begin Message ---
Version: 11.05.13-c1-3+rm

Dear submitter,

as the package camelot has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/642406

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Luca Falavigna (the ftpmaster behind the curtain)


--- End Message ---

Reply to: