[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#641297: package still uses deprecated gtk functions

Package: xdx
Version: 2.4.2-3
Severity: normal
Tags: patch
User: ubuntu-devel@lists.ubuntu.com
Usertags: origin-ubuntu oneiric ubuntu-patch

package still uses deprecated gtk functions, fails to upload on the ubuntu builders.

patch at

build failure

Function `gtk_combo_box_entry_new_text' implicitly converted to pointer at
Function `gtk_set_locale' implicitly converted to pointer at main.c:67

Our automated build log filter detected the problem(s) above that will
likely cause your package to segfault on architectures where the size of
a pointer is greater than the size of an integer, such as ia64 and amd64.

This is often due to a missing function prototype definition.

Since use of implicitly converted pointers is always fatal to the application
on ia64, they are errors.  Please correct them for your next upload.

More information can be found at:

Reply to: