[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#628603: marked as done (synaptic does not start when wdm is the display manager)

Your message dated Sun, 21 Aug 2011 21:01:45 +0200
with message-id <CAHMXK7jjas36Ka5xn4iCFO=7Ynd61Nk5Fbs89gR0kH-oLH6-0g@mail.gmail.com>
and subject line Re: Bug#628603: synaptic does not start when wdm is the display manager
has caused the Debian Bug report #628603,
regarding synaptic does not start when wdm is the display manager
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

628603: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628603
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: wdm
Version: 1.28-6
Severity: important

The title pretty much says it.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)

Kernel: kFreeBSD 8.2-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
2011/6/20 Agustin Martin <agmartin@debian.org>:
> On Fri, Jun 17, 2011 at 11:02:55PM +0430, Eliad Bagherzadegan wrote:
>> On 05/31/2011 02:18 PM, Agustin Martin wrote:
>> > On Mon, May 30, 2011 at 08:57:27PM +0430, Eliad Bagherzadegan wrote:
>> >> Package: wdm
>> >> Version: 1.28-6
>> >> Severity: important
>> >>
>> >> The title pretty much says it.
>> >
>> > Thanks for your info, but more details are really needed.
>> >
>> > I cannot reproduce that problem here in my i386 box when run from a xterm.
>> > Some questions,
>> >
>> > * Did you try with a different display manager? When you noticed the problem?
>> >   Any other relevant change aroud that time?
>> > * Did you call synaptic from a xterm or from a pull-down menu? Does it fail
>> >   when called both ways?
>> > * Is only synaptic which fails?
>> > * Which error did you see? Any relevant info under /var/log?
>> >
>> > Thanks for your feedback,
>> >
>> Sorry for the delay. I had upgraded some packages and did not have keyboard
>> and mouse on X.
>> synaptic works perfectly with slim/openbox, from menu and from lxterminal.
>> Running wdm/openbox,I get this error message in lxterminal:
>> # synaptic
>> No protocol specified
>> (synaptic:20554): Gtk-WARNING **: cannot open display: :0
>> ----------------
>> I've noticed that this only happens when an X application is going to be run
>> as root. For example I could run gedit as a user, but got the same error when
>> I tried o run it as root.

For the records, IMHO this is not a bug, but a feature, so I am
closing this bug report. Please see below for more details.

> Are you exporting XAUTHORITY from user account before becoming root?

Quoting Olaf Märker from an equivakent kdm bug report


  The behavior of kdm, xdm, startx is everytime the same. Usually they create
  the file $HOME/.Xauthority to grant access to X to the user and do not set
  the XAUTHORITY environment variable. Only if they cannot write to
  $HOME/.Xauthority, this file will be created elsewhere (e.g. /tmp) and
  $XAUTHORITY will be set to it.

  How gdm handle this i don't know, but xdm, startx and kdm does so (on my
  computers) and this behavior is described in the xdm man page.
  I think, this is not a bug.

In short, I also think this is not a bug but a feature, wdm just
follows xdm behavior here. Thus, I am closing this bug report.

As pointed out in above bug report, a simple work around to set the
variable is to put

  if [ -z $XAUTHORITY ]; then export XAUTHORITY=~/.Xauthority; fi;

  in $HOME/.bashrc file.



--- End Message ---

Reply to: