[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#629263: mbeq crashes 64-bit Firefox (patch included)

Package: swh-plugins
Version: 0.4.15+1-4

There is a bug in this version of swh-plugins which causes Firefox to crash on 64-bit platforms (see https://bugzilla.mozilla.org/show_bug.cgi?id=650601)

The LV2 port of these plugins has had the problem fixed (https://github.com/swh/ladspa/commit/3b61bb945c5e09ac4f7e0f4805ff80512af93b8e) so I tried backporting the fix to this version, which is still the latest release that works with LADSPA. This fixed the problem and stopped Firefox from crashing, so I am hoping the fix can be included in the official version of the package (as I am assuming the author is no longer interested in maintaining this legacy version of the code, as it has been two years since the bug was fixed in the new port.)

A patch against swh-plugins-0.4.15 to apply the fix can be downloaded from http://www.shikadi.net/files/patches/swh-plugins-0.4.15-mbeq_crash_fix.diff

Reply to: