[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Build-Depend on libdb*-dev, but not linked with -ldb-X.Y

Dear maintainer(s),

your packages depend on Berkeley DB development package, but it is not
linked with any of it's libraries. This could be caused by two major

a) package dropped Berkeley DB support, in that case you are adviced
to remove libdb*-dev from Build-Depends:

b) package cannot find Berkeley DB library to link with and the
Berkeley DB support was dropped unintentionally; in that case please
fix your package

Here is the output of dak for individual packages

mit-scheme: libdb-dev

Most probably (the only) error: 9.0.1-1 in stable has libdb4.8, but
9.0.1-1+b1 dropped the support, most likely reason b), i.e. libdb is
no longer 4.x, but also 5.x.
Please fix.

dovecot: dovecot-common [hurd-i386]
dovecot: libdb-dev

Dependency on libdb dropped in 1:2.0.12-1 (compare with not uptodate
Probably related to this commit:

So, just drop the dependency and forget about Berkeley DB for now
(upstream broke the compatibility already anyway...)

subcommander: libdb-dev
wvstreams: libdb-dev
curl: libdb-dev (>= 4.6)
gnome-launch-box: libdb-dev
glusterfs: libdb-dev
gretl: libdb-dev
gtranslator: libdb-dev (>= 4.3)
ldiskfsprogs: libdb-dev (>= 4.7)

No linking to libdb in stable nor unstable, please check and probably
just drop the dependency on libdb-dev if the functionality is not
needed (nobody noticed, right?)

I'll be filling (minor) bug reports if I don't hear from you on
reasonable time frame (month or two), so we clean-up this ancient mess
in the archive.

Thank you,
Ondřej Surý <ondrej@sury.org>

Reply to: