[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#623648: libxbae4: is the libxp dependency necessary?

Package: libxbae4
Version: 4.60.2-3
Severity: wishlist

The xprint package is obsolete and scheduled for removal. A related
library is libxp, which provides an API that enables client programs
to access and use an Xprint server.  Since we're getting rid of 
xprint, one could argue it makes sense to get rid of libxp as well.

Your package depends on libxp.  This situation sometimes arises
historically from the time before xprint was considered obsolete, with
Build-depends: libxp-dev being set in the past and then forgotten and

This bug has been filed to prompt you to check if you really want
Xprint (libxp) support in your package.

We'll leave libxp in the archives for the time being until you and the 
other packages using it have determined whether you want to keep the
dependency. But we'll be removing xprint itself and other related 
packages now.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: