[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#622962: b43 firmware is too old


Il giorno sab, 16/04/2011 alle 10.38 +0200, Fejes József ha scritto:
> Package: firmware-b43-installer
> Version:
> Hi,
> I'm using a BCM4311. With this package installed, I get this:
> b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)

This is the actually firmware version from firmware-b43-installer

> However a year ago when I installed my system, I didn't find this 
> package, and grabbed the files manually, and I get this:
> b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)

This is the firmware version installed from firmware-b43-lpphy-installer

> My device works with both versions. 

There are some devices that works with both, like your and mine.
(I have 14e4:4318 card)
You could try to install the firmware-b43-lpphy-installer package but I
suspect it will not work, due to a missing chip check on the postinst

> Still, it would be nice if you could 
> provide the newest version. I'll be glad to provide my files upon request.

Perhaps best solution would be to create a list of pci id that works
with both firmware. (I have to also check on b43 web site if already
exist a list of them). If yes, I can add all these cards to the postinst
script, so if the card belongs to one of these you can get the latest
Could you please paste the result of this command?
lspci -n | grep -o "14e4:[1234567890]\+"



Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: