[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#409606: marked as done (git-load-dirs: gets confused by empty dirs and files not under revision-control)



Your message dated Mon, 14 Mar 2011 09:55:30 +0000
with message-id <E1Pz4Us-0000j4-Jc@franck.debian.org>
and subject line Bug#617830: Removed package(s) from unstable
has caused the Debian Bug report #409606,
regarding git-load-dirs: gets confused by empty dirs and files not under revision-control
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
409606: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=409606
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: git-load-dirs
Version: 1.0.35
Severity: normal

When there are any empty dirs (not known to git, which does not track
them), or untracked files in the working copy when running
git_load_dirs, it fails as such:

Syntax: src dest [,src dest [,...]] to move, q to accept, r to redraw:
Command: q
fatal: pathspec 'etc/' did not match any files
Traceback (most recent call last):
  File "/usr/bin/git_load_dirs", line 26, in ?
    init.run("git")
  File "/usr/lib/python2.4/site-packages/tla_support/init.py", line 50, in run
    summary = options.summary).main()
  File "/usr/lib/python2.4/site-packages/tla_support/tla_interact.py", line 109, in main
    self.catchup(needsupdate)
  File "/usr/lib/python2.4/site-packages/tla_support/tla_interact.py", line 123, in catchup
    self.delfile(file)
  File "/usr/lib/python2.4/site-packages/tla_support/tla_interact.py", line 155, in delfile
    self.wcobj.deltag(file)
  File "/usr/lib/python2.4/site-packages/tla_support/tla_wc.py", line 123, in deltag
    [cmd().delete, file])
  File "/usr/lib/python2.4/site-packages/tla_support/util.py", line 111, in chdircmd
    return apply(func, args, kwargs)
  File "/usr/lib/python2.4/site-packages/tla_support/util.py", line 67, in safeexec
    return checkresult(result, expected)
  File "/usr/lib/python2.4/site-packages/tla_support/util.py", line 95, in checkresult
    raise ExecProblem, info + " (expected exit code %d)" % expected
tla_support.util.ExecProblem: exited with code 128 (expected exit code 0)

or:

fatal: pathspec '.all_configs' did not match any files
Traceback (most recent call last):
  File "/usr/bin/git_load_dirs", line 26, in ?
    init.run("git")
  File "/usr/lib/python2.4/site-packages/tla_support/init.py", line 50, in run
    summary = options.summary).main()
  File "/usr/lib/python2.4/site-packages/tla_support/tla_interact.py", line 109, in main
    self.catchup(needsupdate)
  File "/usr/lib/python2.4/site-packages/tla_support/tla_interact.py", line 123, in catchup
    self.delfile(file)
  File "/usr/lib/python2.4/site-packages/tla_support/tla_interact.py", line 155, in delfile
    self.wcobj.deltag(file)
  File "/usr/lib/python2.4/site-packages/tla_support/tla_wc.py", line 123, in deltag
    [cmd().delete, file])
  File "/usr/lib/python2.4/site-packages/tla_support/util.py", line 111, in chdircmd
    return apply(func, args, kwargs)
  File "/usr/lib/python2.4/site-packages/tla_support/util.py", line 67, in safeexec
    return checkresult(result, expected)
  File "/usr/lib/python2.4/site-packages/tla_support/util.py", line 95, in checkresult
    raise ExecProblem, info + " (expected exit code %d)" % expected
tla_support.util.ExecProblem: exited with code 128 (expected exit code 0)


-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (90, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.19.1-smp
Locale: LANG=C, LC_CTYPE=french (charmap=ISO-8859-1)

Versions of packages git-load-dirs depends on:
ii  git-core                     1:1.4.4.3-1 content addressable filesystem
ii  load-dirs-common             1.0.35      Common files for tla-load-dirs and
ii  python                       2.4.4-2     An interactive high-level object-o

git-load-dirs recommends no packages.

-- no debconf information


--- End Message ---
--- Begin Message ---
Version: 1.1.8+rm

Dear submitter,

as the package vcs-load-dirs has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/617830

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Alexander Reichle-Schmehl (the ftpmaster behind the curtain)


--- End Message ---

Reply to: