[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#438238: marked as done (upsd: not handling nostrip build option (policy 10.1))



Your message dated Sun, 20 Feb 2011 01:23:16 +0000
with message-id <E1Pqy16-0003eH-4q@franck.debian.org>
and subject line Bug#473894: Removed package(s) from unstable
has caused the Debian Bug report #438238,
regarding upsd: not handling nostrip build option (policy 10.1)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
438238: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=438238
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: upsd
Version: 2.6-4.1
Severity: wishlist
User: buildd@naquadah.org
Usertags: nostrip

Hello,

There was a problem while autobuilding your package with DEB_BUILD_OPTIONS=nostrip.
Final binaries are still stripped.

If you call dh_strip correctly in debian/rules, this may mean that upstream
is stripping anyway.
You should look for call to strip, ld -s or install -s which may strip binaries.


> Automatic build of upsd_2.6-4.1 on octave for sid/i386 by rebuildd 0.2.2-r136
> Build started at 2007-08-15 19:00:37.011858
> ******************************************************************************
> Reading package lists...
> Building dependency tree...
> Reading state information...
> Need to get 46.8kB of source archives.
> Get:1 http://ftp.fr.debian.org sid/main upsd 2.6-4.1 (dsc) [546B]
> Get:2 http://ftp.fr.debian.org sid/main upsd 2.6-4.1 (tar) [38.6kB]
> Get:3 http://ftp.fr.debian.org sid/main upsd 2.6-4.1 (diff) [7651B]
> Fetched 46.8kB in 0s (195kB/s)
> Download complete and in download only mode
> W: /home/staff/jd/.pbuilderrc does not exist
> I: using fakeroot in build.
> Current time: Wed Aug 15 19:00:45 UTC 2007
> pbuilder-time-stamp: 1187204445
> Building the build Environment
>  -> extracting base tarball [/var/cache/pbuilder/sid.tgz]
>  -> creating local configuration
>  -> copying local configuration
>  -> mounting /proc filesystem
>  -> mounting /dev/pts filesystem
>  -> policy-rc.d already exists
> Obtaining the cached apt archive contents
> Installing the build-deps
>  -> Attempting to parse the build-deps 
>  -> Considering build-dep debhelper (>> 4.0.0)
>    -> Trying debhelper
>  -> Installing  debhelper
> Reading package lists...
> Building dependency tree...
> Reading state information...
> The following extra packages will be installed:
>   file gettext gettext-base html2text intltool-debian libmagic1 po-debconf
> Suggested packages:
>   dh-make cvs gettext-doc
> Recommended packages:
>   curl wget lynx libmail-sendmail-perl libcompress-zlib-perl
> The following NEW packages will be installed:
>   debhelper file gettext gettext-base html2text intltool-debian libmagic1
>   po-debconf
> debconf: delaying package configuration, since apt-utils is not installed
> 0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
> Need to get 0B/3448kB of archives.
> After unpacking 10.7MB of additional disk space will be used.
> Selecting previously deselected package libmagic1.
> (Reading database ... 8969 files and directories currently installed.)
> Unpacking libmagic1 (from .../libmagic1_4.21-2_i386.deb) ...
> Selecting previously deselected package file.
> Unpacking file (from .../archives/file_4.21-2_i386.deb) ...
> Selecting previously deselected package gettext-base.
> Unpacking gettext-base (from .../gettext-base_0.16.1-2_i386.deb) ...
> Selecting previously deselected package html2text.
> Unpacking html2text (from .../html2text_1.3.2a-3_i386.deb) ...
> Selecting previously deselected package gettext.
> Unpacking gettext (from .../gettext_0.16.1-2_i386.deb) ...
> Selecting previously deselected package intltool-debian.
> Unpacking intltool-debian (from .../intltool-debian_0.35.0+20060710.1_all.deb) ...
> Selecting previously deselected package po-debconf.
> Unpacking po-debconf (from .../po-debconf_1.0.9_all.deb) ...
> Selecting previously deselected package debhelper.
> Unpacking debhelper (from .../debhelper_5.0.53_all.deb) ...
> Setting up libmagic1 (4.21-2) ...
> 
> Setting up file (4.21-2) ...
> Setting up gettext-base (0.16.1-2) ...
> 
> Setting up html2text (1.3.2a-3) ...
> 
> Setting up gettext (0.16.1-2) ...
> 
> Setting up intltool-debian (0.35.0+20060710.1) ...
> Setting up po-debconf (1.0.9) ...
> Setting up debhelper (5.0.53) ...
>  -> Finished parsing the build-deps
> Reading package lists...
> Building dependency tree...
> Reading state information...
> fakeroot is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> Copying back the cached apt archive contents
> Copying source file
>     -> copying [upsd_2.6-4.1.dsc]
>     -> copying [./upsd_2.6.orig.tar.gz]
>     -> copying [./upsd_2.6-4.1.diff.gz]
> Extracting source
> gpg: can't open `/gnupg/options.skel': No such file or directory
> gpg: Signature made Sun Feb 26 21:52:32 2006 UTC using DSA key ID A965818F
> gpg: Can't check signature: public key not found
> dpkg-source: extracting upsd in upsd-2.6
> dpkg-source: unpacking upsd_2.6.orig.tar.gz
> dpkg-source: applying ./upsd_2.6-4.1.diff.gz
>  -> Building the package
> Setting DEB_BUILD_OPTIONS=nostrip
> dpkg-buildpackage: source package is upsd
> dpkg-buildpackage: source version is 2.6-4.1
> dpkg-buildpackage: source changed by Matej Vela <vela@debian.org>
> dpkg-buildpackage: host architecture i386
> dpkg-buildpackage: source version without epoch 2.6-4.1
>  fakeroot debian/rules clean
> dh_testdir
> dh_testroot
> rm -f build-stamp install-stamp
> /usr/bin/make realclean
> make[1]: Entering directory `/tmp/buildd/upsd-2.6'
> rm -f common.o net.o upsd.o ups.o mapping.o
> rm -f .depend
> rm -f upsd
> make[1]: Leaving directory `/tmp/buildd/upsd-2.6'
> dh_clean
>  dpkg-source -b upsd-2.6
> dpkg-source: building upsd using existing upsd_2.6.orig.tar.gz
> dpkg-source: building upsd in upsd_2.6-4.1.diff.gz
> dpkg-source: building upsd in upsd_2.6-4.1.dsc
>  debian/rules build
> dh_testdir
> make
> make[1]: Entering directory `/tmp/buildd/upsd-2.6'
> gcc -M *.c -Wall -O2 > .depend;
> gcc  -Wall -O2 -DPWRSTAT="\"/etc/powerstatus\"" \
> 	-DCFGFILE="\"/etc/upsd.conf\"" -DUPSSTAT="\"/etc/upstatus\"" -DVERSION="\"v2.6\"" -c common.c -o common.o
> gcc  -Wall -O2 -DPWRSTAT="\"/etc/powerstatus\"" \
> 	-DCFGFILE="\"/etc/upsd.conf\"" -DUPSSTAT="\"/etc/upstatus\"" -DVERSION="\"v2.6\"" -c net.c -o net.o
> gcc  -Wall -O2 -DPWRSTAT="\"/etc/powerstatus\"" \
> 	-DCFGFILE="\"/etc/upsd.conf\"" -DUPSSTAT="\"/etc/upstatus\"" -DVERSION="\"v2.6\"" -c upsd.c -o upsd.o
> gcc  -Wall -O2 -DPWRSTAT="\"/etc/powerstatus\"" \
> 	-DCFGFILE="\"/etc/upsd.conf\"" -DUPSSTAT="\"/etc/upstatus\"" -DVERSION="\"v2.6\"" -c ups.c -o ups.o
> gcc  -Wall -O2 -DPWRSTAT="\"/etc/powerstatus\"" \
> 	-DCFGFILE="\"/etc/upsd.conf\"" -DUPSSTAT="\"/etc/upstatus\"" -DVERSION="\"v2.6\"" -c mapping.c -o mapping.o
> gcc common.o net.o upsd.o ups.o mapping.o  -o upsd
> strip upsd
> make[1]: Leaving directory `/tmp/buildd/upsd-2.6'
> touch build-stamp
>  fakeroot debian/rules binary
> dh_testdir
> dh_testroot
> dh_clean -k
> dh_installdirs
> make install-upsd DESTDIR=`pwd`/debian/upsd
> make[1]: Entering directory `/tmp/buildd/upsd-2.6'
> strip upsd
> cp upsd /tmp/buildd/upsd-2.6/debian/upsd/sbin
> chmod 755 /tmp/buildd/upsd-2.6/debian/upsd/sbin/upsd
> cp upsd.conf /tmp/buildd/upsd-2.6/debian/upsd/etc
> chmod 644 upsd.conf
> make[1]: Leaving directory `/tmp/buildd/upsd-2.6'
> cp debian/default debian/upsd/etc/default/upsd
> cp Changes.txt debian/upsd/usr/share/doc/upsd/changelog
> touch install-stamp
> dh_testdir
> dh_testroot
> dh_installdocs
> dh_installexamples
> dh_installmenu
> dh_installinit
> dh_installcron
> dh_installman upsd.8
> dh_installchangelogs
> dh_strip
> dh_compress
> dh_fixperms
> dh_installdeb
> dh_shlibdeps
> dh_gencontrol
> dh_md5sums
> dh_builddeb
> dpkg-deb: building package `upsd' in `../upsd_2.6-4.1_i386.deb'.
>  dpkg-genchanges
> dpkg-genchanges: not including original source code in upload
> dpkg-buildpackage: binary and diff upload (original source NOT included)
> Copying back the cached apt archive contents
>  -> unmounting dev/pts filesystem
>  -> unmounting proc filesystem
>  -> cleaning the build env 
>     -> removing directory /var/cache/pbuilder/build//23938 and its subdirectories
> Current time: Wed Aug 15 19:05:05 UTC 2007
> pbuilder-time-stamp: 1187204705
> Checking upsd_2.6-4.1_i386.deb for stripped binaries...
> ---------------------------------------
> /tmp/upsd_2.6-4.1_i386.deb/sbin/upsd: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.8, dynamically linked (uses shared libs), stripped
> 
> ...done
> Removing result files...
> ...done
> ******************************************************************************
> Finished with status POST_BUILD_FAILED at 2007-08-15 19:05:10.698241
> Build needed 0:04:33.686383

-- 
Julien Danjou
.''`.  Debian Developer
: :' : http://julien.danjou.info
`. `'  http://people.debian.org/~acid
  `-   9A0D 5FD9 EB42 22F6 8974  C95C A462 B51E C2FE E5CD


--- End Message ---
--- Begin Message ---
Version: 2.6-5+rm

Dear submitter,

as the package upsd has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/473894

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Luca Falavigna (the ftpmaster behind the curtain)


--- End Message ---

Reply to: