[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#463598: /var/run/utmp exists, but wdm still doesn't register the session

On Thu, May 27, 2010 at 07:37:37PM +0200, Agustin Martin wrote:
> On Fri, May 21, 2010 at 09:36:47PM +0300, Yury Bulka wrote:
> > 
> > Hello! Let me firstly thank you for your work on this package and for reading this:)
> > So here's what the report is about:
> > I've also noticed that wdm doesn't register the session it starts to utmp, but in my case /var/run/utmp exists on my system.
> > It's strange, because the "sessreg" command is in its place in file /etc/X11/wdm/Xstartup:
> > ---
> > # Insert a utmp entry for the session
> > if grep -q ^use-sessreg /etc/X11/wdm/wdm.options; then
> >   exec sessreg -a -l $DISPLAY -u /var/run/utmp -x /etc/X11/wdm/Xservers $USER
> > fi
> > ---
> > and the option "use-sessreg" is enabled in /etc/X11/wdm/wdm.options.
> > I tried to install xdm and it does register the session with almost identical "sessreg" command (the only difference is the -x parameter which is set to "/etc/X11/xdm/Xservers" there)...
> I replaced wdm Xstartup with xdm Xstartup and s/xdm/wdm/g. No luck, it still
> does not register session. I have verified that $DISPLAY and $USER values
> just before the sessreg call are correct and so that the sessreg line is
> processed if use-sessreg is enabled.
> I am curious, did it register session at some time?
> In the box where wdm is installed last time /var/log/wdm.log was updated was
> long time ago, on November 2005 for sid. I wonder what happened at that time.
> I think about something related to xfree86 -> xorg transition (last xfree86 
> log in this sid box is from September 2005).

By the way, just noticed why "/var/log/wdm.log" was not updated. It was indeed
the expected behavior.

Somewhere around 1.27 (Seems to be 1.27-1, according to changelog, in reply
to #242155), "wdm-config" was modified to have messages be sent to syslog 
as default, while previous default was "/var/log/wdm.log". And that
happened in late 2004 amd hit me in 2005.

I have checked my "/var/log/syslog" and it indeed contains wdm messages. 
If I modify "wdm-config" to not use syslog, messages are sent again to

Adam, I am aware this bug is 3 years old and you no longer use wdm, but do 
you remember if when noticing the problem you checked "/var/log/wdm.log", 
or it was "/var/log/syslog"?

Thanks for your feedback,


Reply to: