[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#538251: marked as done (zsh: "git add" completion does not work with relative paths)

Your message dated Thu, 10 Feb 2011 03:28:24 +0100
with message-id <20110210022823.GB12557@sym.noone.org>
and subject line Bug#538251 (zsh: "git add" completion does not work with relative paths) seems to be fixed in Sid
has caused the Debian Bug report #538251,
regarding zsh: "git add" completion does not work with relative paths
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

538251: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=538251
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: zsh
Version: 4.3.10-3
Severity: normal

Programmable completion for the "git add" command does not work with relative file names or paths. To reproduce:

# Create a git repository
$ mkdir repo
$� cd repo
$� git init

# Create a new file
$ touch somefile

# Add that file to the index with a relative path
$ mkdir subdir
$ cd subdir
$ git add ../some<TAB>    # Fails to complete

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-1-686 (SMP w/2 CPU cores)
Locale: LANG=fi_FI@euro, LC_CTYPE=fi_FI@euro (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages zsh depends on:
ii  libc6                     2.9-21         GNU C Library: Shared libraries
ii  libcap2                   1:2.16-5       support for getting/setting POSIX.
ii  libncursesw5              5.7+20090613-1 shared libraries for terminal hand

Versions of packages zsh recommends:
ii  libc6                         2.9-21     GNU C Library: Shared libraries
ii  libpcre3                      7.8-2+b1   Perl 5 Compatible Regular Expressi

Versions of packages zsh suggests:
ii  zsh-doc                       4.3.10-3   zsh documentation - info/HTML form

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 4.3.11-2

While this bug still occurs in Squeeze's version of zsh (4.3.10-14),
it seems to be fixed in Sid's current version (4.3.11-2).

Closing this bug report accordingly.

		Regards, Axel
 ,''`.  |  Axel Beckert <abe@debian.org>, http://people.debian.org/~abe/
: :' :  |  Debian Developer, ftp.ch.debian.org Admin
`. `'   |  1024D: F067 EA27 26B9 C3FC 1486  202E C09E 1D89 9593 0EDE
  `-    |  4096R: 2517 B724 C5F6 CA99 5329  6E61 2FF9 CD59 6126 16B5

--- End Message ---

Reply to: