[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#603450: Patch not possible with pytho 2.4 compatibility

Was just pointed to this bug. The fix would probably work, however only
under python >= 2.6. ssl_wrapper calls ssl.wrap() under 2.6, but socket.ssl()
under Python 2.4 and 2.5.

And socket.ssl does not take these parameters:
cert_reqs=..., ca_certs=...

So either we have to give up python 2.5 compatability and require 2.6
for SSL connections, or do more work to work on python 2.4


Reply to: