[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#513087: marked as done (bcm43xx-fwcutter not replaced by b43-fwcutter when upgrading)

Your message dated Tue, 23 Nov 2010 09:47:03 +0100
with message-id <1290502023.8035.5.camel@alexander>
and subject line #513087 is probably no longer relevant
has caused the Debian Bug report #513087,
regarding bcm43xx-fwcutter not replaced by b43-fwcutter when upgrading
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

513087: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=513087
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: b43-fwcutter
Version: 1:011-5
Severity: important

Hash: RIPEMD160

 When upgrading from Etch to Lenny, b43-fwcutter is not automatically
installed even if bcm43xx-fwcutter was previously installed.

 This obviously make the wireless card to stop working (at least on
the iBook G4) once the kernel get upgraded from 2.6.18 to 2.6.26,
so we have a lost of functionality when upgrading to Lenny.

 That in itself is not too bad, as it can easily be fixed by manually
installing b43-fwcutter. Well, at least if the GUI and XOrg is still
working properly after upgrading. If not, you have a problem because the
text terminal is barely usable, thanks to khelper who continously call
ifplugd and cause it to print the following 4 lines every second on the

 input: b43-phy0 as /class/input/input208
 firmware: requesting b43/ucode5.fw
 b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found or load failed.
 b43-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the latest firmware (version 4).

 The only thing needed to be able to upgrade directly from Etch to Lenny
is a virtual package named bcm43xx-fwcutter that would install b43-fwcutter
(and maybe also remove the old bcm43xx-fwcutter and bcm43xx-source packages).

 Since it is very easy to do, and that it give a much better user experience
when upgrading from Etch, I don't see a reasons for not doing this in Lenny.

 Thank you in advance,

Simon Valiquette

- -- System Information:
Debian Release: 5.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.26-1-vserver-powerpc (SMP w/1 CPU core)
Locale: LANG=fr_CA, LC_CTYPE=fr_CA (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/dash

- -- debconf information:
  b43-fwcutter/cut_firmware: true

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---
--- Begin Message ---
Version: 1:011-5


This bug report is about upgrading etch -> lenny. However, etch is no
longer supported[1] and lenny already has b43-fwcutter[2], so there
won't be any problem when upgrading to squeeze. I'm therefore closing
this bug as fixed in lenny. Feel free to reopen if necessary.

Best regards

Alexander Kurtz

[1] http://debian.org/News/2010/20100121
[2] http://packages.debian.org/lenny/b43-fwcutter

Attachment: signature.asc
Description: This is a digitally signed message part

--- End Message ---

Reply to: