[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#553841: replacing libreadline5-dev build dependency with libreadline-dev



On Mon, 2 Nov 2009 02:10:46 +0100 (MET) Matthias Klose wrote:

> Package: rpncalc
> Version: 1.36.8
> Severity: important
> User: doko@debian.org
> Usertags: readline6
>
[...]
> Both libreadline-dev (>= 6.0) and libreadline6-dev are now available
> in unstable and testing. If possible, please replace the libreadline5-dev
> build dependency with libreadline-dev, so that in future changes of the
> libreadline soname binNMU's can be used for this kind of update.

Hello, I am an rpncalc user.
I noticed this bug report and I have a little comment to drop...

I am under the impression that the change you request is not possible,
since

  * rpncalc is released under GPL v2 only
  * readline5 is released under GPL v2 or later
  * readline6 is released under GPL v3 or later
  * GPL v3 is incompatible with GPL v2

Please correct me, if I am overlooking something.

Maybe rpncalc may be adapted to use libedit, which is released under a
3-clause BSD license?


-- 
 http://www.inventati.org/frx/progs/scripts/pdebuild-hooks.html
 Need some pdebuild hook scripts?
..................................................... Francesco Poli .
 GnuPG key fpr == C979 F34B 27CE 5CD8 DC12  31B5 78F4 279B DD6D FCF4

Attachment: pgpwrqbn9T6sM.pgp
Description: PGP signature


Reply to: