[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#599627: ipppd removed, but is still needed

Package: isdnutils
Version: 1:3.9.20060704+dfsg.1-3
Severity: grave

ipppd is needed to set up a synchronous PPP connection through the
old ISDN4Linux drivers.

The favoured means to set up a synchronous PPP connection now is to
use pppdcapiplugin and an ISDN driver that supports CAPI, but there
apparently no such drivers for many of the devices supported by the
old ISDN4Linux drivers.

I removed ipppd because it contains some source files with BSD-style
licences including an advertising clause, and some licenced under GPL.
This combination is incompatible and thus binaries are
undistributable.  However, the latter files contain just 3 functions
which are based on BSD-licenced code from pppd and can easily be


-- System Information:
Debian Release: squeeze/sid
  APT prefers proposed-updates
  APT policy: (500, 'proposed-updates'), (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages isdnutils depends on:
pn  isdnlog                     <none>       (no description available)
pn  isdnutils-base              <none>       (no description available)
pn  isdnutils-xtools            <none>       (no description available)
pn  isdnvboxclient              <none>       (no description available)
pn  isdnvboxserver              <none>       (no description available)
ii  openbsd-inetd [inet-superse 0.20080125-6 The OpenBSD Internet Superserver

isdnutils recommends no packages.

Versions of packages isdnutils suggests:
pn  capiutils                     <none>     (no description available)
pn  isdnutils-doc                 <none>     (no description available)
pn  pppdcapiplugin                <none>     (no description available)

Reply to: