[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#581557: marked as done (kwave: FTBFS error: --add-needed is not supported but is required for libkfile.so.4)

Your message dated Mon, 14 Jun 2010 09:34:08 +0000
with message-id <E1OO63U-0004Sd-6W@ries.debian.org>
and subject line Bug#581557: fixed in kwave 0.8.5-1-1
has caused the Debian Bug report #581557,
regarding kwave: FTBFS error: --add-needed is not supported but is required for libkfile.so.4
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

581557: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581557
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: kwave
Version: 0.8.2-3
Severity: serious
Tags: squeeze
Justification: FTBFS

Build fails:

    [ 44%] Built target kwave_core
    make[4]: Entering directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    Scanning dependencies of target plugin_about_automoc
    make[4]: Leaving directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    make[4]: Entering directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    Generating KwaveAboutContainer.moc
    Generating AboutPlugin.moc
    Generating AboutKwaveDialog.moc
    Generating LogoWidget.moc
    make[4]: Leaving directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    [ 44%] Built target plugin_about_automoc
    make[4]: Entering directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    [ 44%] Generating ui_KwaveAboutDialogBase.h
    Scanning dependencies of target plugin_about
    make[4]: Leaving directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    make[4]: Entering directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    [ 44%] Building CXX object plugins/about/CMakeFiles/plugin_about.dir/plugin_about_automoc.o
    [ 44%] Building CXX object plugins/about/CMakeFiles/plugin_about.dir/AboutKwaveDialog.o
    [ 44%] Building CXX object plugins/about/CMakeFiles/plugin_about.dir/AboutPlugin.o
    /srv/deb/rc/kwave/kwave.git/plugins/about/AboutPlugin.cpp:25: warning: 'name' initialized and declared 'extern'
    /srv/deb/rc/kwave/kwave.git/plugins/about/AboutPlugin.cpp:25: warning: 'author' initialized and declared 'extern'
    /srv/deb/rc/kwave/kwave.git/plugins/about/AboutPlugin.cpp:25: warning: 'version' initialized and declared 'extern'
    [ 45%] Building CXX object plugins/about/CMakeFiles/plugin_about.dir/KwaveAboutContainer.o
    [ 45%] Building CXX object plugins/about/CMakeFiles/plugin_about.dir/LogoWidget.o
    Linking CXX shared library about
    /usr/bin/ld: error: --add-needed is not supported but is required for libkfile.so.4 in /srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu/libgui/libk\
    collect2: ld returned 1 exit status
    make[4]: *** [plugins/about/about] Error 1
    make[4]: Leaving directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    make[3]: *** [plugins/about/CMakeFiles/plugin_about.dir/all] Error 2
    make[3]: Leaving directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/srv/deb/rc/kwave/kwave.git/obj-x86_64-linux-gnu'
    make[1]: *** [debian/stamp-makefile-build] Error 2
    make[1]: Leaving directory `/srv/deb/rc/kwave/kwave.git'
    dpkg-buildpackage: error: debian/rules build gave error exit status 2
    debuild: fatal error at line 1330:

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_DK.UTF-8, LC_CTYPE=en_DK.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
Source: kwave
Source-Version: 0.8.5-1-1

We believe that the bug you reported is fixed in the latest version of
kwave, which is due to be installed in the Debian FTP archive:

  to main/k/kwave/kwave_0.8.5-1-1.debian.tar.gz
  to main/k/kwave/kwave_0.8.5-1-1.dsc
  to main/k/kwave/kwave_0.8.5-1-1_amd64.deb
  to main/k/kwave/kwave_0.8.5-1.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 581557@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Mark Purcell <msp@debian.org> (supplier of updated kwave package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Mon, 14 Jun 2010 17:50:41 +1000
Source: kwave
Binary: kwave
Architecture: source amd64
Version: 0.8.5-1-1
Distribution: unstable
Urgency: low
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Mark Purcell <msp@debian.org>
 kwave      - sound editor for KDE
Closes: 497269 581557
 kwave (0.8.5-1-1) unstable; urgency=low
   * New upstream release (Closes: #581557)
   * NEW Maintainer: Debian KDE Extras Team
     <pkg-kde-extras@lists.alioth.debian.org> (Closes: #497269)
   * Drop local doc/ changes
   * Add debian/watch
   * Drop Obsolete Conflicts: Provides:
   * source/format -> 3.0 (quilt)
   * Switch to dh 7 - drop cdbs
   * Update lintian-overrides
   * Update Standards-Version: 3.8.4 - Added Vcs:
 0445c8bfd653847c8d4d6f81e64721be03ab4c22 1551 kwave_0.8.5-1-1.dsc
 2a13a3b3e470ce50061dcd70edcbd3cf024c7df1 3053896 kwave_0.8.5-1.orig.tar.gz
 f2f08cba4ede73b9b3f85f1fc013ec4e9dc1cdb9 13661 kwave_0.8.5-1-1.debian.tar.gz
 37d1d75bf828946ab3f5d89784e6b0d6d4eeedf1 8837964 kwave_0.8.5-1-1_amd64.deb
 a260176839823002c5d06f898ed663a053ab3a142c8be34423ab4b033cc54fe6 1551 kwave_0.8.5-1-1.dsc
 cf547e3df8387dd84a5f5457d1eabb4856496f52de12ba882f218f7dfe37ff26 3053896 kwave_0.8.5-1.orig.tar.gz
 57bba9fb8d3fe5eb59cb2bd44682c97fce2c3d9a0b811358c3cf732dfe6c7f3b 13661 kwave_0.8.5-1-1.debian.tar.gz
 0d9615e7e48cdd6719c38bb6630cdc7c1715fe0891fc83f948f5291a4afd621f 8837964 kwave_0.8.5-1-1_amd64.deb
 41a8c780e99f9b740ead206f98dc0076 1551 kde optional kwave_0.8.5-1-1.dsc
 310cc6b7aebe099af511b14f47f73762 3053896 kde optional kwave_0.8.5-1.orig.tar.gz
 74de54758ffbf93003e44b45c1f960c9 13661 kde optional kwave_0.8.5-1-1.debian.tar.gz
 c281f12c73a2fe56e3d0e1648fb68dad 8837964 kde optional kwave_0.8.5-1-1_amd64.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: