[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#576252: marked as done (openntpd: line 60 of /etc/init.d/ntpd: invalid option '-u' stops init of ntpd on start)

Your message dated Thu, 3 Jun 2010 23:07:08 +0200
with message-id <20100603210708.GA11907@phoenix.lloedy.com>
and subject line Invalid bug
has caused the Debian Bug report #576252,
regarding openntpd: line 60 of /etc/init.d/ntpd: invalid option '-u' stops init of ntpd on start
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

576252: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=576252
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: openntpd
Version: 3.9p1-7
Severity: important

line 60 of /etc/init.d/ntpd, search to u near end of line, and delete u $UIGID
(or some other variable, I don't remember but it was similar to that) fixes it.
sudo ntpd -s still works fine, it's just the init script that is broken.

-- System Information:
Debian Release: squeeze/sid
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages openntpd depends on:
ii  adduser                       3.112      add and remove users and groups
ii  libc6                         2.10.2-6   Embedded GNU C Library: Shared lib
ii  libssl0.9.8                   0.9.8m-2   SSL shared libraries

openntpd recommends no packages.

openntpd suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
I am closing this bug with resolution "invalid" since:

- There is no /etc/init.d/ntpd  belonging to package openntpd.
- /etc/init.d/openntpd do not have any variable named $UIGID
- the swith "-u" cannot be found either in /etc/init.d/openntpd
- the init script works fine on my machine.

--- End Message ---

Reply to: