[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#463598: wdm: sessreg invocation in Xstart up and Xreset doesn't work

At Mon, 31 May 2010 15:42:51 +0200,
Agustin Martin wrote:
> On Fri, Feb 01, 2008 at 12:50:25PM -0500, Adam C. Emerson wrote:
> > Package: wdm
> > Version: 1.28-2.3
> > Severity: normal
> > 
> > 
> > Due to the nonexistence of utmp on my newly installed system, the
> > -u /var/log/utmp option to sessreg causes it to not reg sesses.
> > Removing this option makes everything work perfectly.
> Looking at some bugs in this orphaned package.
> Not sure if is a typo, but is /var/run/utmp what is used, not /var/log/utmp.
> Anyway, seems that in systems with /var/run/utmp there is still no log. See 
> followup to your bug report,
> http://bugs.debian.org/463598
> I tried removing the '-u /var/run/utmp' part from Xstartup, but seems to
> still not register sessions. Are wdm sesions registered at your site with
> the change?
> I compared code in wdm and xdm Xstartups and they looked very similar, so I
> guess this problem originates somewhere else.
> In the box where wdm is installed last time /var/log/wdm.log was updated was
> long time ago, on November 2005 for sid. I wonder what happened at that
> time. I think about something related to xfree86 -> xorg transition (last 
> xfree86 log in this sid box is from September 2005).
> Thanks for your feedback,

I've switched to using xdm now (it's working fine at my site.)

Reply to: