[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#570575: pydance: XS-P-V: current and Python 2.6 as default

Package: pydance
Severity: important
User: debian-python@lists.debian.org
Usertags: python2.6


This package has `XS-Python-Version: current' field in debian/control
file and it builds `Architure: all' binary package containing Python
modules, that were only built for the default Python version.

Because of this, the binary package currently depends on `python (<<
2.6)', and thus it will need a sourceful upload after switching
default version of Python to 2.6.

Use of the 'current' keyword is deprecated. Please consider updating
your package to not enforce a particular Python version (that
happened to be the default at build time), for example by setting
`XS-Python-Version' either to `>> 2.4' or `all'.


Reply to: