[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#569586: FTBFS: compiler errors, when libc6-dev < 2.10.2-2

Package: gmrun
Version: 0.9.2-1
Tags: patch

gmrun fails to build from source when using the libc6 from Debian
stable. It appears that libc6 was changed in a non backwards-compatible
way sometime between 2.7 and 2.10.2.

Removing the 60-fix_gtkcompletionline.patch will allow it to compile in
stable, but then it won't compile in unstable/testing anymore. The
simplest solution would be for Build-Depends to require "libc6-dev (>=
2.10.2-2)". Or you could ammend the 60-fix_gtkcompletionline.patch to
check for libc6 version, and define my_alphasort accordingly.


Attachment: signature.asc
Description: PGP signature

Reply to: