[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#421774: marked as done (Segmentation fault at startup during or after login in to ICQ)

Your message dated Thu, 14 Jan 2010 19:18:30 +0000
with message-id <E1NVVDC-00073J-9e@ries.debian.org>
and subject line Bug#421774: fixed in licq 1.3.8-1
has caused the Debian Bug report #421774,
regarding Segmentation fault at startup during or after login in to ICQ
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

421774: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=421774
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: licq
Version: 1.3.4-2
Severity: important

Hash: SHA1

Since yesterday, I have an obscure problem with lICQ. When I start lICQ
in offline mode, everything is ok. But when I login, it receives a
segmentation fault:

$ LANG=C licq
Licq Segmentation Violation Detected.
licq(licq_handle_sigsegv+0xc9) [0x80ee239]
licq(_ZN10CICQDaemon17ProcessVariousFamER7CBuffert+0x1f3a) [0x80bcada]
licq(_ZN10CICQDaemon18ProcessDataChannelER7CBuffer+0xc9) [0x80c0da9]
licq(_ZN10CICQDaemon16ProcessSrvPacketER7CBuffer+0x160) [0x80c0fa0]
licq(_Z18MonitorSockets_tepPv+0x386) [0x80c2fe6]
/lib/libpthread.so.0 [0xb7dae5a3]
/lib/libc.so.6(__clone+0x5e) [0xb7be503e]
Attempting to generate core file.

The backtrace isn't that interesting atm.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1225831536 (LWP 19961)]
0x080c7c60 in ICQUser::GetInGroup ()
(gdb) bt full
#0  0x080c7c60 in ICQUser::GetInGroup ()
No symbol table info available.
#1  0x080bcada in CICQDaemon::ProcessVariousFam ()
No symbol table info available.
#2  0x080c0da9 in CICQDaemon::ProcessDataChannel ()
No symbol table info available.
#3  0x080c0fa0 in CICQDaemon::ProcessSrvPacket ()
No symbol table info available.
#4  0x080c2fe6 in MonitorSockets_tep ()
No symbol table info available.
#5  0xb7e155a3 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#6  0xb7c4c03e in clone () from /lib/libc.so.6
No symbol table info available.

I will recompile licq with debugging symbols and send you this backtrace
too. Do you want the output of `-d 16' too?

Severity is set to important, because this issue makes the software
unusable for me.

Regards, Daniel

- -- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (850, 'unstable'), (700, 'testing'), (550, 'stable'), (110, 'experimental')
Architecture: i386 (i686)

Kernel: Linux (PREEMPT)
Locale: LANG=de_DE, LC_CTYPE=de_DE (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages licq depends on:
ii  libc6                         2.5-4      GNU C Library: Shared libraries
ii  libgcc1                       1:4.1.2-5  GCC support library
ii  libgpg-error0                 1.4-2      library for common error values an
ii  libgpgme11                    1.1.2-5    GPGME - GnuPG Made Easy
ii  libssl0.9.8                   0.9.8e-4   SSL shared libraries
ii  libstdc++6                    4.1.2-5    The GNU Standard C++ Library v3
ii  licq-plugin-console [licq-plu 1.3.4-2    console user interface plug-in for
ii  licq-plugin-kde [licq-plugin] 1.3.4-2    graphical user interface plug-in f
ii  licq-plugin-qt [licq-plugin]  1.3.4-2    graphical user interface plug-in f

Versions of packages licq recommends:
ii  sox                           13.0.0-1   Swiss army knife of sound processi

- -- debconf-show failed

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---
--- Begin Message ---
Source: licq
Source-Version: 1.3.8-1

We believe that the bug you reported is fixed in the latest version of
licq, which is due to be installed in the Debian FTP archive:

  to main/l/licq/licq-dev_1.3.8-1_all.deb
  to main/l/licq/licq-plugin-autoreply_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-console_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-forwarder_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-kde_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-msn_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-osd_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-qt_1.3.8-1_amd64.deb
  to main/l/licq/licq-plugin-rms_1.3.8-1_amd64.deb
  to main/l/licq/licq_1.3.8-1.diff.gz
  to main/l/licq/licq_1.3.8-1.dsc
  to main/l/licq/licq_1.3.8-1_amd64.deb
  to main/l/licq/licq_1.3.8.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 421774@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Erik Johansson <debian@ejohansson.se> (supplier of updated licq package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Sat, 09 Jan 2010 17:27:46 +0100
Source: licq
Binary: licq licq-dev licq-plugin-autoreply licq-plugin-console licq-plugin-forwarder licq-plugin-kde licq-plugin-msn licq-plugin-osd licq-plugin-qt licq-plugin-rms
Architecture: source all amd64
Version: 1.3.8-1
Distribution: unstable
Urgency: low
Maintainer: Erik Johansson <debian@ejohansson.se>
Changed-By: Erik Johansson <debian@ejohansson.se>
 licq       - ICQ client (base files)
 licq-dev   - Licq development and header files
 licq-plugin-autoreply - autoreply plug-in for Licq
 licq-plugin-console - console user interface plug-in for Licq
 licq-plugin-forwarder - forwarder plug-in for Licq
 licq-plugin-kde - graphical user interface plug-in for Licq using Qt and KDE
 licq-plugin-msn - MSN plug-in for Licq
 licq-plugin-osd - on-screen display plug-in for Licq
 licq-plugin-qt - graphical user interface plug-in for Licq using Qt
 licq-plugin-rms - remote management server plug-in for telnet Licq access
Closes: 282933 421774 425748 471819
 licq (1.3.8-1) unstable; urgency=low
   * New maintainer (closes: #471819)
   * New upstream release 1.3.8 (closes: #421774, #425748, #282933)
   * Removed fix-const.patch, merged upstream
   * debian/licq.docs
     - Dropped docs no longer shipped upstream
   * Backport r7000, r6978, r7023, r7087 from upstream, fixing potential bugs.
   * Bumped Standards Version to 3.8.3 with no changes.
 63a5b777583f39ae1b005123b3b3e74a7122d9a3 1449 licq_1.3.8-1.dsc
 cff5256e49d54108c16ff826e8bdb7254834b293 5913256 licq_1.3.8.orig.tar.gz
 03c3620e8aa8e05cc36ed3f34a7027156000e160 26983 licq_1.3.8-1.diff.gz
 4bc87c8d195b8fd6c5d4814e76514d998b7dde5a 101904 licq-dev_1.3.8-1_all.deb
 bc93d518ab399b32a91f8e6cd4ac1d2b2fd0bdb6 822268 licq_1.3.8-1_amd64.deb
 e873f45c02163402a3a44ec54a54f2ab6a42f836 42042 licq-plugin-autoreply_1.3.8-1_amd64.deb
 7cbcd8e54d6aa5a319d6ec53e90579c0da67afd8 96480 licq-plugin-console_1.3.8-1_amd64.deb
 1e464fc9ddc23bd8b507cdfa722da6bb9decfa1a 43744 licq-plugin-forwarder_1.3.8-1_amd64.deb
 0bba80e76d2fe296af735dbbb2e33d21fea55c9d 1915548 licq-plugin-kde_1.3.8-1_amd64.deb
 687a8f02a0844019061bfc1c6f5142aafbe61ce9 96064 licq-plugin-msn_1.3.8-1_amd64.deb
 2d4192d107ca80796351ce0d45fb5ce739060a2a 60650 licq-plugin-osd_1.3.8-1_amd64.deb
 0c59610602950e6dcfe155a539d986ecb516c0b1 1875364 licq-plugin-qt_1.3.8-1_amd64.deb
 f733e266965552629cd328186762319c81c4a861 55172 licq-plugin-rms_1.3.8-1_amd64.deb
 52cda4f51c90331dbd981eede9cf11046b16f44636a6656273d947cbe627fb99 1449 licq_1.3.8-1.dsc
 e66797037612b862b34edc12d12ff53ee55cb6e74d490ab44a39742ffb553ebc 5913256 licq_1.3.8.orig.tar.gz
 cbf606c5907b5c808e4eec8f2c6d6bf7f7b1d96b80e8cd4446c2c24934a8bd60 26983 licq_1.3.8-1.diff.gz
 1b0f903a2be7ce26f5ae487c79def0cc334680f68539ca931b4736570734c4d3 101904 licq-dev_1.3.8-1_all.deb
 177352f9ec98fab2443d60019a01ab9e5a63890a2ba58776151491c87eeda6d4 822268 licq_1.3.8-1_amd64.deb
 6f16b71b85930dfa7587f2fa48ec8e4839a811df68dfbd857fe5657fd042ff37 42042 licq-plugin-autoreply_1.3.8-1_amd64.deb
 7ee2c06731effd4e4e65e2ede2986eb18ded39a04586333c2afec45e94d91572 96480 licq-plugin-console_1.3.8-1_amd64.deb
 5dbc40510b0e2e6603307f6c3480c3b16b1e5554b0dd01884cfb8d9a8bd43518 43744 licq-plugin-forwarder_1.3.8-1_amd64.deb
 bbdeaa47adcaeeafc9a5b5b8b7b739df9ecf238cd17648c4d60db800af5a72d1 1915548 licq-plugin-kde_1.3.8-1_amd64.deb
 d866831a64b16c8ec701f5cc34f60d209d6af7bb538a7f10b446f045c8206cbf 96064 licq-plugin-msn_1.3.8-1_amd64.deb
 26b4f1c34c375b89b0629241a203b5ffc729cc4114bcdccdd621f694a5096bea 60650 licq-plugin-osd_1.3.8-1_amd64.deb
 1775eaa8808b9b2c66d479790d3f0fa2b0528127c9b6cbd6976f3ee986d42677 1875364 licq-plugin-qt_1.3.8-1_amd64.deb
 2f35301c722632d4813d7aa2a59dbdab934cc10eb565aea9abe6d0c3bfc723ea 55172 licq-plugin-rms_1.3.8-1_amd64.deb
 1009590b562f6efb354f4418f41ff42f 1449 net optional licq_1.3.8-1.dsc
 d34e7a71572802fed7ab9aec9ddd583a 5913256 net optional licq_1.3.8.orig.tar.gz
 ac2cc846c1e1d063990dc68f2389f375 26983 net optional licq_1.3.8-1.diff.gz
 6106ee5635acaba0dc18e9282668b1d5 101904 libdevel optional licq-dev_1.3.8-1_all.deb
 65b1993664d4da8b2f913a9a614e8bbd 822268 net optional licq_1.3.8-1_amd64.deb
 8334dca45f3df609d9465eb5f7c44489 42042 net optional licq-plugin-autoreply_1.3.8-1_amd64.deb
 750c0f51011645c462810db1964fabe1 96480 net optional licq-plugin-console_1.3.8-1_amd64.deb
 e114eaac271220ba521c1d55910d83b4 43744 net optional licq-plugin-forwarder_1.3.8-1_amd64.deb
 c00736b7293d9e31cd03b0721ff4b31a 1915548 net optional licq-plugin-kde_1.3.8-1_amd64.deb
 84dd86f05da633b2df992eb245f18a45 96064 net optional licq-plugin-msn_1.3.8-1_amd64.deb
 d941de08d47ceabb6ae85c030b91eb80 60650 net optional licq-plugin-osd_1.3.8-1_amd64.deb
 de9d39294ba9f4b3fcec3c371cdee7ff 1875364 net optional licq-plugin-qt_1.3.8-1_amd64.deb
 94f1f013b8edc3d007a1b5e144d3e314 55172 net optional licq-plugin-rms_1.3.8-1_amd64.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: