[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#562407: graphviz: Depends on python2.4 packages

dktrkranz@debian.org wrote:
> Source: graphviz
> Version: 2.20.2-6
> Severity: important
> User: debian-python@lists.debian.org
> Usertags: python2.4-removal
> Squeze will release with Python 2.5 and Python 2.6, while Python 2.4
> is scheduled for removal when no packages will depend on it. Recent
> python-defaults disabled support for Python 2.4 already, so it is no
> longer supported version for module and extension building.
> This package build-depends or depends on one or more packages built
> on top of the python2.4 source package, and will be uninstallable
> when they will be removed from Sid and Squeeze.
> You should consider dropping build-dependencies and dependencies on
> those packages, checking if code is compatible with newer releases of
> Python. These links explain changes introduced and should ease your
> work:
> * http://docs.python.org/whatsnew/2.5.html
> * http://docs.python.org/whatsnew/2.6.html 


I'm currently working on the packaging for the latest upstream version
(2.26.0) and I have made the necessary changes in the git repo on
collab-maint [1]

I do not currently anticipate any need to update the 2.20 version.




Reply to: