[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#553280: defoma: read-in-maintainer-script postinst:20

severity 553280 important

On Thu, 29 Oct 2009, Manoj Srivastava wrote:
>  This maintainer script appears to use read to get information from
>  the user. Prompting in maintainer scripts must be done by
>  communicating through a program such as debconf which conforms to
>  the Debian Configuration management specification, version 2 or
>  higher.

Yeah, this prompting is in a codepath that won't be triggered anymore.
[It's for upgrading from a version of defoma which we don't distribute
anymore, and I didn't notice it when I was making a minimal QA release

Since defoma should go away, I'm not going to bother to make a QA
release where I just delete this codepath, but the next time someone
makes an upload (if that actually happens) it should get deleted.
Downgrading to important so people don't needlessly waste time looking
at this bug.

Don Armstrong

CNN/Reuters: News reports have filtered out early this morning that US
forces have swooped on an Iraqi Primary School and detained 6th Grade 
teacher Mohammed Al-Hazar. Sources indicate that, when arrested,
Al-Hazar was in possession of a ruler, a protractor, a set square and
a calculator. US President George W Bush argued that this was clear
and overwhelming evidence that Iraq indeed possessed weapons of math 

http://www.donarmstrong.com              http://rzlab.ucr.edu

Reply to: