[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#530172: marked as done (qtparted: bashism in /bin/sh script)

Your message dated Sat, 27 Jun 2009 09:25:33 +0000
with message-id <E1MKUA9-0002qO-Rz@ries.debian.org>
and subject line Bug#530172: fixed in qtparted 0.4.5-5
has caused the Debian Bug report #530172,
regarding qtparted: bashism in /bin/sh script
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

530172: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530172
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: qtparted
Severity: important
Version: 0.4.5-4+b1
User: debian-release@lists.debian.org
Usertags: goal-dash

Hello maintainer,

While performing an archive wide checkbashisms (from the 'devscripts' package)
check I've found your package containing a /bin/sh script making use
of a bashism.

checkbashisms' output:
> possible bashism in ./usr/sbin/run_qtparted line 13 (should be read [-r]
> variable):
>	  read -p "Your mouse selection: " mymouse

Not using bash (or a Debian Policy conformant shell interpreter which doesn't
provide such an extra feature) as /bin/sh is likely to lead to errors or
unexpected behaviours.
Please be aware that although bash is currently the default /bin/sh there was
a release goal for Lenny to make dash the default /bin/sh[1], and has been
proposed for squeeze as well[2].

If you want more information about dash as /bin/sh, you can read:

For more information supporting this goal please refer to Debian Policy,
section 10.4, at:

Hints about how to fix bashisms:
Sometimes these bugs are already fixed in Ubuntu, look at the PTS.
If not already fixed you can read:

If you still don't know how to fix the bashisms don't hesitate to reply to
this email, or tag the bug as 'help'.


Thank you,
Raphael Geissert

--- End Message ---
--- Begin Message ---
Source: qtparted
Source-Version: 0.4.5-5

We believe that the bug you reported is fixed in the latest version of
qtparted, which is due to be installed in the Debian FTP archive:

  to pool/main/q/qtparted/qtparted_0.4.5-5.diff.gz
  to pool/main/q/qtparted/qtparted_0.4.5-5.dsc
  to pool/main/q/qtparted/qtparted_0.4.5-5_amd64.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 530172@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Filippo Giunchedi <filippo@debian.org> (supplier of updated qtparted package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Sat, 27 Jun 2009 10:51:53 +0200
Source: qtparted
Binary: qtparted
Architecture: source amd64
Version: 0.4.5-5
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Filippo Giunchedi <filippo@debian.org>
 qtparted   - A parted frontend using QT
Closes: 530172 534001
 qtparted (0.4.5-5) unstable; urgency=low
   * QA upload.
   * data/run_qtparted.in: fix bashism (Closes: #530172)
   * src/qp_libparted.cpp: replace ped_free with free (Closes: #534001)
   * pass DEB_BUILD/HOST_GNU_TYPE to configure
 390cb635ca43e3ff466a7b9f7a6426e8965c9363 1187 qtparted_0.4.5-5.dsc
 d2ff00a798265477904fedf33f58d360e6858128 262610 qtparted_0.4.5-5.diff.gz
 edb8e865360a4bd04806f7d2abb7b5163535796a 219748 qtparted_0.4.5-5_amd64.deb
 99dea7fb4f20c7fc1e26f55f3c3be54d4b04967108cc3a7ac6a5399b944cf63b 1187 qtparted_0.4.5-5.dsc
 f56091ea1bda7c95c58d5cff37dea17edbc60c2ee148a285448cc4d6765dcdae 262610 qtparted_0.4.5-5.diff.gz
 9a69cb22da2be5606300f6104b4e451e4cc140dfd37b15e3e1caf74ad94cbdc2 219748 qtparted_0.4.5-5_amd64.deb
 1a3662a192ef7dca06de77c1de7183b8 1187 x11 optional qtparted_0.4.5-5.dsc
 82572c4d4a1019573e58689cbdf94798 262610 x11 optional qtparted_0.4.5-5.diff.gz
 d3a91b3cb454c3b00fb4628fd195f4ee 219748 x11 optional qtparted_0.4.5-5_amd64.deb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: