[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#530879: marked as done (missing a lot of dependencies, not available in Debian)

Your message dated Sat, 20 Jun 2009 13:32:32 +0000
with message-id <E1MI0gK-0000u7-N3@ries.debian.org>
and subject line Bug#530879: fixed in turbogears2 2.0-3
has caused the Debian Bug report #530879,
regarding missing a lot of dependencies, not available in Debian
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

530879: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530879
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: python-turbogears2
Version: 2.0-1
Severity: grave

According to the only doc available (i.e. upstream, as the package
does not contain any), installing the python-turbogears2 package does
not provide a working tg2 environment.

Indeed "paster --help" reports no info whatsoever about tg2:

  zack@usha:~$ dpkg -l python-turbogears2 | tail -n 1
  ii  python-turbogears2                    2.0-1                       Python-based web framework, version 2
  zack@usha:~$ paster --help | grep TurboGe

while the last grep should output something like:

    quickstart   Create a new TurboGears 2 project.
    tginfo       Show TurboGears 2 related projects and their versions

The diagnosis is confirmed by actually trying to use quickstart to
start a tg2 project:

  zack@usha:~$ paster quickstart
  Command 'quickstart' not known (you may need to run setup.py egg_info)
  Known commands:
    create       Create the file layout for a Python distribution
    exe          Run #! executable files
    help         Display help
    make-config  Install a package and create a fresh config file/directory
    points       Show information about entry points
    post         Run a request for the described application
    request      Run a request for the described application
    serve        Serve the described application
    setup-app    Setup an application, given a config file
  Traceback (most recent call last):
    File "/usr/bin/paster", line 18, in <module>
    File "/usr/lib/pymodules/python2.5/paste/script/command.py", line 84, in run
      invoke(command, command_name, options, args[1:])
    File "/usr/lib/pymodules/python2.5/paste/script/command.py", line 123, in invoke
      exit_code = runner.run(args)
    File "/usr/lib/pymodules/python2.5/paste/script/command.py", line 778, in run
    File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1912, in load
      if require: self.require(env, installer)
    File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1925, in require
    File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 524, in resolve
      raise DistributionNotFound(req)  # XXX put more info here
  pkg_resources.DistributionNotFound: repoze.tm2>=1.0a4

same goes for the other expected command, tg-info.

Out of curiosity: how did you the maintainer test the package?  I'd
like to know to understand whether I'm doing something wrong on my
side or not. At the current state of the affair, tg2 is unusable, at
least here.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages python-turbogears2 depends on:
ii  python                        2.5.4-2    An interactive high-level object-o
ii  python-nose                   0.11.1-1   test discovery and running for Pyt
ii  python-pylons                 0.9.7-1    Python web framework emphasizing f
ii  python-support                1.0.3      automated rebuilding support for P
ii  python-tempita                0.4-1      very small text templating languag
ii  python-turbojson              1.2.1-1    TurboGears template plugin to use 
ii  python-turbokid               1.0.4-4    TurboGears template plugin to use 
ii  python-weberror               0.10.1-1   Python web error handling and exce
ii  python-webhelpers             0.6.4-1    Library of helper functions to mak
ii  python-webob          Python module providing WSGI reque

Versions of packages python-turbogears2 recommends:
ii  python-elixir                 0.6.1-2    Declarative Mapper for SQLAlchemy
ii  python-pysqlite2              2.5.5-1    Python interface to SQLite 3

Versions of packages python-turbogears2 suggests:
ii  python-genshi                 0.5.1-1    Python XML-based template engine

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: turbogears2
Source-Version: 2.0-3

We believe that the bug you reported is fixed in the latest version of
turbogears2, which is due to be installed in the Debian FTP archive:

  to pool/main/t/turbogears2/python-turbogears2_2.0-3_all.deb
  to pool/main/t/turbogears2/turbogears2_2.0-3.diff.gz
  to pool/main/t/turbogears2/turbogears2_2.0-3.dsc

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 530879@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Stefano Zacchiroli <zack@debian.org> (supplier of updated turbogears2 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Sat, 20 Jun 2009 15:15:37 +0200
Source: turbogears2
Binary: python-turbogears2
Architecture: source all
Version: 2.0-3
Distribution: experimental
Urgency: low
Maintainer: Stefano Zacchiroli <zack@debian.org>
Changed-By: Stefano Zacchiroli <zack@debian.org>
 python-turbogears2 - Python web application framework
Closes: 530879 532729
 turbogears2 (2.0-3) experimental; urgency=low
   [ Stefano Zacchiroli ]
   * adopting package
   * new upstream release
   * resurrect packaging from last Python Modules Team work, with the
     blessing of the last maintainer there; thanks Gustavo Noronha Silva!
   * empty README.Debian, now obsolete
   * debian/control
     - set Maintainer to Python Modules Team, Uploaders to me
     - recommend python-tg.devtools, to get "paster quickstart"
     - revamp Description
     - sync (build-)dependencies with what currently required
       (Closes: #530879, #532729)
     - bump Standards-Version to 3.8.2 (no changes needed)
   * debian/watch: make it point to current download site
   * debian/rules: remove simple-patchsys, as we have no patches anymore
   [ Sandro Tosi ]
   * debian/control
     - switch Vcs-Browser field to viewsvn
 f681649340c8b28dcbecb0f7f922e831aca454e7 1306 turbogears2_2.0-3.dsc
 0e50bee011bd4b4314bbd115ad679ff89dec097d 6575 turbogears2_2.0-3.diff.gz
 f964f007ed9dae886e3743e02e96b9b9f1fb7e79 68600 python-turbogears2_2.0-3_all.deb
 017263216ffaba676177f89f45d1b07c12190e4c64abc61a734e78e68562df6a 1306 turbogears2_2.0-3.dsc
 872375d0629291543518f850f868fd98382fabda3afc7fce6897dea6c7e1da7c 6575 turbogears2_2.0-3.diff.gz
 c97fc090d800e2c5eb8b40aad1f5ebc242b88f073fc4a4b219c218b0710e0ea9 68600 python-turbogears2_2.0-3_all.deb
 23ca60fa46dd7865603039dda45405e0 1306 python optional turbogears2_2.0-3.dsc
 62c4bb690a40766acfcb8ca96b4e8778 6575 python optional turbogears2_2.0-3.diff.gz
 8840afaed3b1e7f470adcaa7adfc5492 68600 python optional python-turbogears2_2.0-3_all.deb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: