[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#531980: mdbtools-gmdb: FTBFS because of missing libglade2-dev Build-Depends

Package: mdbtools-gmdb
Severity: serious
Tags: patch
Justification: no longer builds from source

The current mdbtools package fails to build from source.  It used to, because the libbonoboui-dev Build-Depends used to pull in libglade2-dev for us.  But we should list it explicitly now.  libbonoboui-dev no longer does it for us.

The reason libglade2-dev is necessary is because ./configure checks for it, doesn't find it, and so doesn't build the gmdb2 executable.  Install fails because it isn't found.

Trivial patch attached.

-- System Information:
Debian Release: squeeze/sid
  APT prefers karmic-updates
  APT policy: (500, 'karmic-updates'), (500, 'karmic-security'), (500, 'karmic')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-7-generic (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages mdbtools-gmdb depends on:
ii  libart-2.0-2 2.3.20-2                    Library of functions for 2D graphi
ii  libatk1.0-0  1.26.0-1                    The ATK accessibility toolkit
ii  libbonobo2-0 2.24.1-1                    Bonobo CORBA interfaces library
ii  libbonoboui2 2.24.1-1ubuntu1             The Bonobo UI library
ii  libc6        2.9-9ubuntu2                GNU C Library: Shared libraries
ii  libcairo2    1.8.6-1ubuntu2              The Cairo 2D vector graphics libra
ii  libfontconfi 2.6.0-1ubuntu12             generic font configuration library
ii  libgconf2-4  2.26.2-0ubuntu1             GNOME configuration database syste
ii  libglade2-0  1:2.6.4-1                   library to load .glade files at ru
ii  libglib2.0-0 2.21.1-0ubuntu1             The GLib library of C routines
ii  libgnome-key 2.26.1-0ubuntu1             GNOME keyring services library
ii  libgnome2-0  2.26.0-1ubuntu1             The GNOME library - runtime files
ii  libgnomecanv 2.26.0-1                    A powerful object-oriented display
ii  libgnomeui-0 2.24.1-1                    The GNOME 2 libraries (User Interf
ii  libgnomevfs2 1:2.24.1-1ubuntu1           GNOME Virtual File System (runtime
ii  libgtk2.0-0  2.16.1-0ubuntu3             The GTK+ graphical user interface 
ii  libice6      2:1.0.5-1                   X11 Inter-Client Exchange library
ii  libmdbtools mdbtools libraries
ii  liborbit2    1:2.14.17-0.1               libraries for ORBit2 - a CORBA ORB
ii  libpango1.0- 1.24.2-1ubuntu1             Layout and rendering of internatio
ii  libpopt0     1.14-4                      lib for parsing cmdline parameters
ii  libsm6       2:1.1.0-2                   X11 Session Management library
ii  libx11-6     2:1.2.1-1                   X11 client-side library
ii  libxcursor1  1:1.1.9-1build1             X cursor management library
ii  libxext6     2:         X11 miscellaneous extension librar
ii  libxfixes3   1:4.0.3-2build1             X11 miscellaneous 'fixes' extensio
ii  libxi6       2:1.2.1-2ubuntu1            X11 Input extension library
ii  libxinerama1 2:1.0.3-2                   X11 Xinerama extension library
ii  libxml2      2.6.32.dfsg-5ubuntu4        GNOME XML library
ii  libxrandr2   2:1.3.0-2                   X11 RandR extension library
ii  libxrender1  1:0.9.4-2                   X Rendering Extension client libra

mdbtools-gmdb recommends no packages.

mdbtools-gmdb suggests no packages.

-- no debconf information
diff -u mdbtools- mdbtools-
--- mdbtools-
+++ mdbtools-
@@ -2,7 +2,7 @@
 Section: utils
 Priority: optional
 Maintainer: Debian QA Group <packages@qa.debian.org>
-Build-Depends: bison, cdbs, debhelper (>= 5), flex, libgnomeui-dev, libncurses5-dev, libreadline5-dev, texinfo, unixodbc-dev
+Build-Depends: bison, cdbs, debhelper (>= 5), flex, libgnomeui-dev, libncurses5-dev, libreadline5-dev, texinfo, unixodbc-dev, libglade2-dev
 Standards-Version: 3.7.2
 Package: mdbtools

Reply to: