[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#386601: marked as done (jabber fails to listen on INADDR_ANY)

Your message dated Fri, 27 Mar 2009 22:27:08 +0000
with message-id <E1LnKW4-0003gW-Ni@ries.debian.org>
and subject line Bug#386601: fixed in jabberd14
has caused the Debian Bug report #386601,
regarding jabber fails to listen on INADDR_ANY
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

386601: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=386601
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: jabber
Version: 1.4.3-3
Severity: minor

When starting the jabber daemon with the default config in debug mode
(/usr/sbin/jabberd -D, the following messages show up:

    io_select unable to listen on port 5222 [(null)]: jabberd already
    running or invalid interface?

The default config file has this line:

    <ip port="5222"/>

Changing it to

    <ip port="5222"></ip>

makes it work, and jabber will bind to the port (the same must be done for
port 5269) and afterwards jabber will show up in `netstat -ltpn`.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /UNIONFS/bin/bash
Kernel: Linux 2.6.15
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages jabber depends on:
ii  jabber-common                 0.4        Jabber server and transport (commo
ii  libc6                         2.3.6-7    GNU C Library: Shared libraries
ii  libexpat1                     1.95.8-3   XML parsing C library - runtime li
ii  libpth2                       2.0.7-2    The GNU Portable Threads
ii  libssl0.9.7                   0.9.7i-2   SSL shared libraries
ii  procps                        1:3.2.5-1  /proc file system utilities

jabber recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: jabberd14

We believe that the bug you reported is fixed in the latest version of
jabberd14, which is due to be installed in the Debian FTP archive:

  to pool/main/j/jabberd14/jabber_1.6.1.1-1_all.deb
  to pool/main/j/jabberd14/jabberd14_1.6.1.1-1.diff.gz
  to pool/main/j/jabberd14/jabberd14_1.6.1.1-1.dsc
  to pool/main/j/jabberd14/jabberd14_1.6.1.1-1_i386.deb
  to pool/main/j/jabberd14/jabberd14_1.6.1.1.orig.tar.gz
  to pool/main/j/jabberd14/libjabberd2-dev_1.6.1.1-1_i386.deb
  to pool/main/j/jabberd14/libjabberd2_1.6.1.1-1_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 386601@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Miguel Landaeta <miguel@miguel.cc> (supplier of updated jabberd14 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Tue, 17 Feb 2009 11:21:36 -0430
Source: jabberd14
Binary: jabber jabberd14 libjabberd2-dev libjabberd2
Architecture: source all i386
Distribution: unstable
Urgency: low
Maintainer: Jens Peter Secher <jps@debian.org>
Changed-By: Miguel Landaeta <miguel@miguel.cc>
 jabber     - Transitional package for jabber rename
 jabberd14  - Instant messaging server using the Jabber/XMPP protocol
 libjabberd2 - Runtime library for the Jabber/XMPP instant messaging server
 libjabberd2-dev - Development files for the Jabber/XMPP instant messaging server
Closes: 302417 329680 334414 337542 350337 386601 404816 404816 407166 430529 438871 471408 489071
 jabberd14 ( unstable; urgency=low
   [ Miguel Landaeta ]
   * New maintainer. (Closes: #471408)
   * New upstream release. (Closes: #329680, #430529)
   * debian/copyright:
     - Upstream now uses license GPL-2+. (Closes: #302417)
     - Implement a version of the copyright format proposal.
   * Bumped standards version to 3.8.0; no changes required.
   * Provided a new binary package libjabberd2 and renamed
     jabber-dev package to libjabberd2-dev.
   * Updated debian/jabberd14.postinst:
      - Copy spool data from /var/lib/jabber to /var/spool/jabberd.
   [ Paul van Tilburg ]
   * Renamed source and binary packages to jabberd14; conflict with
     and provide jabber. (Closes: #404816).
   * Updated debian/rules since jabberd14 now uses autotools; converted it
     to use CDBS. (Closes: #337542).
   * Added --enable-ipv6 flag for configure in debian/rules.
     (Closes: #334414, #386601).
   * Added debian/jabber.xml.xdb_file to install as default configuration;
     use file-based XDB for now.
   * Updated debian/control:
     - Changed build-depend from libssl-dev to libgnutls-dev.
     - Added build-depends on libpopt-dev, cdbs and pkg-config.
     - Removed the build-depend on procps.
     - Added depend on openssl to be able to generate dhparams.pem.
     - Changed ${jabber:Provides} into hardcoded jabber-1.4
     - Slight update to the description of the libjabber2-dev package.
       (Closes: #404816).
   * Added the Homepage field.
   * Updated and created more files for debhelper to be used with
     jabberd14, libjabberd2 and libjabberd2-dev packages.
   * Added a watch file.
   * Added depend on lsb-base (>= 3.0-6) and updated init script to use
     LSB functions. (Closes: #350337, #489071, #407166).
   * Added a man page for xdbfiletool: debian/xdbfiletool.8.
   * Dropped depend on jabber-common.
   * Removed debian/jabberd14.preinst, it wasn't doing anything anymore.
   * Updated debian/jabberd.14.post{inst,rm}:
      - Create/remove jabberd system user and group. (Closes: #438871).
      - Generate/remove /etc/jabber/dhparams.pem.
      - Chown and chmod/clean the configuration and spool directory.
 ab89062136094d67c852be415f2a4c60468513cc 1359 jabberd14_1.6.1.1-1.dsc
 8b7ba77c9e02e9de7125e898900ff0ba5d65986e 834112 jabberd14_1.6.1.1.orig.tar.gz
 6a246f0e1d0b4ecb820bca067fa719f18d6afb75 25333 jabberd14_1.6.1.1-1.diff.gz
 88cc7cd0c9dc4d150b7f55caadb19ca36a6d2670 24448 jabber_1.6.1.1-1_all.deb
 503b645622d334a6fe8f793e62e8798edc47cdda 355084 jabberd14_1.6.1.1-1_i386.deb
 b0e839dc317caacd4ff41aa683f2d4b0c405cd75 44450 libjabberd2-dev_1.6.1.1-1_i386.deb
 8ed2dda756c509372a726ebf0952f5d08dab2603 150496 libjabberd2_1.6.1.1-1_i386.deb
 4bd008df28af56fd2b72474bbbd48775d4d49e61d31944d4418910a682df98b8 1359 jabberd14_1.6.1.1-1.dsc
 8bba7f8e8781a088679bdcf0e46348a29da45de3eec2421f73575c5a6b8ddc31 834112 jabberd14_1.6.1.1.orig.tar.gz
 46758dc05d3e43f9da614ac34ffc8ed6bba8563d4afe2c678e3ba1d73af88c27 25333 jabberd14_1.6.1.1-1.diff.gz
 902d70a6a9d535f5c8d381ce8d413ec210e452b9033aa03e86e1504b4de6413e 24448 jabber_1.6.1.1-1_all.deb
 5c76fbf7728dcc80665dfd0702294d119fee64af81e418ae341fb6b38016098b 355084 jabberd14_1.6.1.1-1_i386.deb
 e1daa91f8211150e9e07f9173527bae66ee1d29602fbb8a03a936407116b1a8a 44450 libjabberd2-dev_1.6.1.1-1_i386.deb
 b4b684498de88479b2de8e7429eff39bb7032592500bd19c15ad2b815c951f21 150496 libjabberd2_1.6.1.1-1_i386.deb
 7675c5e2815c727d7f7a6c4bec603dbf 1359 net optional jabberd14_1.6.1.1-1.dsc
 597c7ee14518ba22b1cee883b4737d87 834112 net optional jabberd14_1.6.1.1.orig.tar.gz
 d706bd94e6213de6f606abcc84662bc1 25333 net optional jabberd14_1.6.1.1-1.diff.gz
 9ecc452f66ae7b56d26fd66ee37bb1db 24448 net optional jabber_1.6.1.1-1_all.deb
 87b8845edf2586499345142e9470f59c 355084 net optional jabberd14_1.6.1.1-1_i386.deb
 dd08a8bd18e742fe03a0d1da0f3d73d2 44450 libdevel optional libjabberd2-dev_1.6.1.1-1_i386.deb
 7873724ce385cb76f36ec64ed9170c43 150496 libs optional libjabberd2_1.6.1.1-1_i386.deb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: