[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#514921: libmimedir0: tries to overwrite file owned by libmimedir-gnome0-dev

Package: libmimedir0
Version: 0.5.1-1
Severity: serious


automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:

Date: 2009-02-11
Architecture: amd64
Distribution: sid
Command: apt-get --assume-yes --allow-unauthenticated install libmimedir-gnome0-dev libmimedir0

Reading package lists...
Building dependency tree...
The following extra packages will be installed:
  libglib2.0-0 libmimedir-gnome0.4 libpcre3
Recommended packages:
The following NEW packages will be installed:
  libglib2.0-0 libmimedir-gnome0-dev libmimedir-gnome0.4 libmimedir0 libpcre3
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 1319kB of archives.
After this operation, 3584kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libpcre3 libglib2.0-0 libmimedir-gnome0.4 libmimedir-gnome0-dev libmimedir0
Authentication warning overridden.
Get:1 http://localhost sid/main libpcre3 7.8-2 [215kB]
Get:2 http://localhost sid/main libglib2.0-0 2.16.6-1 [826kB]
Get:3 http://localhost sid/main libmimedir-gnome0.4 0.4.2-1 [109kB]
Get:4 http://localhost sid/main libmimedir-gnome0-dev 0.4.2-1 [144kB]
Get:5 http://localhost sid/main libmimedir0 0.5.1-1 [25.6kB]
Fetched 1319kB in 3s (439kB/s)
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package libpcre3.
(Reading database ... 7961 files and directories currently installed.)
Unpacking libpcre3 (from .../libpcre3_7.8-2_amd64.deb) ...
Selecting previously deselected package libglib2.0-0.
Unpacking libglib2.0-0 (from .../libglib2.0-0_2.16.6-1_amd64.deb) ...
Selecting previously deselected package libmimedir-gnome0.4.
Unpacking libmimedir-gnome0.4 (from .../libmimedir-gnome0.4_0.4.2-1_amd64.deb) ...
Selecting previously deselected package libmimedir-gnome0-dev.
Unpacking libmimedir-gnome0-dev (from .../libmimedir-gnome0-dev_0.4.2-1_amd64.deb) ...
Selecting previously deselected package libmimedir0.
Unpacking libmimedir0 (from .../libmimedir0_0.5.1-1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libmimedir0_0.5.1-1_amd64.deb (--unpack):
 trying to overwrite `/usr/lib/libmimedir.a', which is also in package libmimedir-gnome0-dev
Processing triggers for man-db ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is a serious bug as it makes installation fail. Possible
solutions are to have the two packages conflict, to rename the common
file in one of the two packages, or to remove the file from one
package and have this package depend on the other package. File
diversions or a Replace relation are another possibility.

This bug will be assigned to both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package.


-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.utf8)
Shell: /bin/sh linked to /bin/bash

Reply to: