[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#511766: clig: tcl Version defunct

Package: clig
Severity: important
Tags: patch

The tcl Version of the clig package does no longer work:

 ~/ # echo package require clig |tclsh
can't find package clig

This can be fixed with a symbolic link:

 ~/ # for i in /usr/share/tcltk/tcl8.*; do ln -s /usr/share/clig/ $i; done

 ~/ # echo 'package require clig; puts [package present clig]' |tclsh

BTW, as far as the dependencies of clig are concerned. clig does work with
any Version of tcl starting from 8.0 to 8.5.

I think it's rather inconvenient when tcl8.4 is installed just because of an
invalid clig dependency.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages clig depends on:
ii  tcl8.4                        8.4.19-2   Tcl (the Tool Command Language) v8
ii  tk8.4                         8.4.19-2   Tk toolkit for Tcl and X11, v8.4 -

clig recommends no packages.

clig suggests no packages.

-- debconf-show failed

Reply to: