[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#484738: Transcriber crashes under Tcl 8.5

RT> transcriber doesn't seem to work when tk8.5 is installed. I will
RT> upload a new package with conflict to tk8.5 -Ralf.

In my testing, it isn't that there's any strange conflict caused by
having Tk 8.5 merely existing on the system. Rather, the problem is
more straightforwardly that transcriber works fine when run with
Tcl/Tk 8.4, but fails when run with Tcl/Tk 8.5. Though transcriber
explicitly depends on version 8.4, I think the problem is that the
wrapper shell script just calls "/usr/bin/wish", which could point to
any version depending on /etc/alternatives.

So it seems to me that a more useful fix would be to change the
/usr/bin/transcriber wrapper script so that it refers to
/usr/bin/wish8.4 (resp. tclsh8.4) explicitly; for instance, this would
work correctly if the user has a local version of wish earlier in
their path. My biggest problem with the Conflicts: approach is that it
prevents installing other software that uses Tcl/Tk 8.5: for instance
wordnet, which would also be useful for linguists. Providing an
explicit path is also in the spirit of section 3.2 of the Tcl/Tk


(As for the actual cause of the failure under 8.5, I think it's a
problem in tcLex, which I've reported separately as bug #487549)

 -- Stephen

Reply to: