[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#454866: marked as done (FTBFS with GCC 4.3: missing #includes)

Your message dated Thu, 20 Mar 2008 00:32:05 +0000
with message-id <E1Jc8hR-000863-4u@ries.debian.org>
and subject line Bug#454866: fixed in lineak-defaultplugin 1:0.9-4.1
has caused the Debian Bug report #454866,
regarding FTBFS with GCC 4.3: missing #includes
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

454866: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=454866
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: lineak-defaultplugin
Version: 1:0.9-4
Usertags: ftbfs-gcc-4.3

Your package fails to build with GCC 4.3.  Version 4.3 has not been
released yet but I'm building with a snapshot in order to find errors
and give people an advance warning.  In GCC 4.3, the C++ header
dependencies have been cleaned up.  The advantage of this is that
programs will compile faster.  The downside is that you actually
need to directly #include everything you use (but you really should
do this anyway, otherwise your program won't work with any compiler
other than GCC).  There's some more information about this at

You can reproduce this problem with gcc-snapshot from unstable.  Note
that Red Hat, Novell and Ubuntu have done some work getting packages
to build with GCC 4.3 so there might be patches floating around
somewhere.  I suggest you talk to your upstream.

> Automatic build of lineak-defaultplugin_1:0.9-4 on em64t by sbuild/amd64 0.53
>  x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -DCONFDIR=\"/etc\" -I. -I. -I.. -I.. -I. -I -I/usr/include/lineak -I/usr/include -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -MT defaultplugin.lo -MD -MP -MF .deps/defaultplugin.Tpo -c defaultplugin.cpp  -fPIC -DPIC -o .libs/defaultplugin.o
> defaultplugin.cpp:187: warning: unused parameter 'obj'
> defaultplugin.cpp:187: warning: unused parameter 'command'
> defaultplugin.cpp: In function 'void macroEAK_SYM(LObject*, LCommand&, int)':
> defaultplugin.cpp:333: warning: conversion to 'int' from 'size_t' may alter its value
> defaultplugin.cpp:348: error: 'strcpy' was not declared in this scope

Martin Michlmayr

--- End Message ---
--- Begin Message ---
Source: lineak-defaultplugin
Source-Version: 1:0.9-4.1

We believe that the bug you reported is fixed in the latest version of
lineak-defaultplugin, which is due to be installed in the Debian FTP archive:

  to pool/main/l/lineak-defaultplugin/lineak-defaultplugin_0.9-4.1.diff.gz
  to pool/main/l/lineak-defaultplugin/lineak-defaultplugin_0.9-4.1.dsc
  to pool/main/l/lineak-defaultplugin/lineak-defaultplugin_0.9-4.1_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 454866@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Moritz Muehlenhoff <jmm@debian.org> (supplier of updated lineak-defaultplugin package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu, 20 Mar 2008 01:24:26 +0100
Source: lineak-defaultplugin
Binary: lineak-defaultplugin
Architecture: source i386
Version: 1:0.9-4.1
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Moritz Muehlenhoff <jmm@debian.org>
 lineak-defaultplugin - LinEAK default plugin
Closes: 454866
 lineak-defaultplugin (1:0.9-4.1) unstable; urgency=low
   * Non-maintainer upload.
   * Fix GCC 4.3 compatibility, patch by Cyril Brulebois (Closes: #454866)
 fce8af6e1cd1bed5e58bb605df1c2b83 785 x11 optional lineak-defaultplugin_0.9-4.1.dsc
 33e01c44de074741ff6f01d3e1a0a513 3381 x11 optional lineak-defaultplugin_0.9-4.1.diff.gz
 a0ff7f3b4747295db5e11e59e1714c7f 53134 x11 optional lineak-defaultplugin_0.9-4.1_i386.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: