[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#470631: xmon: xmond does not open Unix socket for display :0

Package: xmon
Version: 1.5.6-2
Severity: normal

xmond -port 42 -server :0
(Also without the -server option)

connect(5, {sa_family=AF_INET, sin_port=htons(6000), sin_addr=inet_addr("")}, 16) = -1 ECONNREFUSED (Connection refused)

Passing a hostname or an IP address to xmond makes it use *that* host,
but there is no way to make it connect to /tmp/.X11-unix/X0

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (100, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-k7 (SMP w/1 CPU core)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages xmon depends on:
ii  libc6                       2.7-6        GNU C Library: Shared libraries
ii  libice6                     2:1.0.4-1    X11 Inter-Client Exchange library
ii  libsm6                      2:1.0.3-1+b1 X11 Session Management library
ii  libx11-6                    2:1.0.3-7    X11 client-side library
ii  libxaw7                     2:1.0.4-1    X11 Athena Widget library
ii  libxext6                    1:1.0.3-2    X11 miscellaneous extension librar
ii  libxmu6                     2:1.0.4-1    X11 miscellaneous utility library
ii  libxt6                      1:1.0.5-3    X11 toolkit intrinsics library

xmon recommends no packages.

-- no debconf information

Reply to: