[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#464786: gtkpbbuttons sometimes prevents audio from working (makes /dev/dsp busy)

Package: gtkpbbuttons
Version: 0.6.9-1
Severity: normal

Each time I tried to play audio (ogg stream), I got an error. For
instance, with ogg123:

ALSA lib pcm_dmix.c:866:(snd_pcm_dmix_open) unable to open slave
ALSA snd_pcm_open error: Device or resource busy
Error: Cannot open device alsa.

I tried other devices, like oss, and still got an error. Ditto with
VLC using esd (/dev/dsp: Device or resource busy). I saw with lsof
that gtkpbbuttons was using /dev/dsp0. I killed the process... and
alsa and esd now work again.

Note: I restarted gtkpbbuttons and no longer have this problem. So, it
seems that under some conditions, gtkpbbuttons is locking /dev/dsp.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (900, 'testing'), (900, 'stable'), (200, 'unstable')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.18-5-powerpc
Locale: LANG=POSIX, LC_CTYPE=en_US.ISO8859-1 (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages gtkpbbuttons depends on:
ii  gtkpbbuttons-common           0.6.9-1    GTK client for pbbuttonsd -- theme
ii  libatk1.0-0                   1.20.0-1   The ATK accessibility toolkit
ii  libaudiofile0                 0.2.6-7    Open-source version of SGI's audio
ii  libc6                         2.7-6      GNU C Library: Shared libraries
ii  libcairo2                     1.4.14-1   The Cairo 2D vector graphics libra
ii  libfontconfig1                2.4.2-1.2  generic font configuration library
ii  libglib2.0-0                  2.14.5-2   The GLib library of C routines
ii  libgtk2.0-0                   2.12.5-2   The GTK+ graphical user interface 
ii  libpango1.0-0                 1.18.4-1   Layout and rendering of internatio
ii  libpopt0                      1.10-3     lib for parsing cmdline parameters
ii  libx11-6                      2:1.0.3-7  X11 client-side library
ii  libxcursor1                   1:1.1.9-1  X cursor management library
ii  libxext6                      1:1.0.3-2  X11 miscellaneous extension librar
ii  libxfixes3                    1:4.0.3-2  X11 miscellaneous 'fixes' extensio
ii  libxi6                        2:1.1.3-1  X11 Input extension library
ii  libxinerama1                  1:1.0.2-1  X11 Xinerama extension library
ii  libxrandr2                    2:1.2.2-1  X11 RandR extension library
ii  libxrender1                   1:0.9.4-1  X Rendering Extension client libra
ii  pbbuttonsd                    0.7.9-2    PBButtons daemon to handle special

gtkpbbuttons recommends no packages.

-- no debconf information

Reply to: