[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#444826: [Fwd: synaptic feast]

retitle 444826 slapd preinst script fails
tags 444826 unreproducible moreinfo

> Synaptic wasn't in the list of the bug report utility so I had to use
> the email.  I don't know whom is the fault but I had a few packages
> still marked even after I applied the changes.  I was getting tired of
> seeing the same errors at each installation os I tried removiong the
> faulty packages and now I'm stuck with an even biger problem !  more of
> them listed and even 2 broken packages ...  mostly related to gnome.
> So to start off I had 3 packages and now I got a dozen, the original
> were SLAPD, and 2 gnome librairies in which the only recongnised
> dependency were WineX.
> I have some text pop up in a console when the same error pops up after
> applying changes which is  BREAKING NEWS ! while tring to get the list I
> conldn't because of the broken ones and now I'm back to the original
> culprits which give me this error :
> E: /cdrom//pool/main/g/gtk+1.2/libgtk1.2-common_1.2.10-18_all.deb:
> subprocess pre-installation script returned error exit status 2
> E: /cdrom//pool/main/g/gtk+1.2/libgtk1.2_1.2.10-18_amd64.deb: subprocess
> new post-removal script returned error exit status 2
> E: /cdrom//pool/main/l/linux-2.6/linux-image-2.6.18-5-amd64_2.6.18.dfsg.1-13_amd64.deb: subprocess new pre-removal script returned error exit status 2
> E: /cdrom//pool/main/o/openldap2.3/slapd_2.3.30-5_amd64.deb: subprocess
> pre-installation script returned error exit status 2

I'm sorry, but I'm afraid that this bug report doesn't make any sense to
me.  I understand that you have a set of packages that you're trying to
install, including slapd, which are not installing properly, but beyond
that I don't understand the sequence of events that led to this.

The error that you're seeing indicates that something fairly fundamental
is broken with your system, I think.  It looks like the preinst scripts of
basically every package you're trying to install are failing.  My guess is
that this is not a problem with any of the specific packages installed and
instead is something more fundamentally corrupted in your system.

Normally, there should be some error message when scripts fail, not just
the E: messages that you show above.  Without some additional idea of
what's failing, I'm not sure how to help.

My guess is that this is a problem that you probably want to take to
debian-user@lists.debian.org instead of the BTS, at least until you sort
out what happened to your system and how to recover.

Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>

Reply to: