[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#443850: htdig problem in postinst



package: htdig
x-debbugs-cc: linux-fai@rrz.uni-koeln.de

Hi,

On Monday 24 September 2007 17:15, Tim Cutts wrote:
> That's probably worth filing as a bug in the htdig package.  Its
> postinst script should probably be explicitly setting $verbose to a
> suitable value, or unsetting it, within the script.  It certainly
> shouldn't be using it uninitialised and just trusting the calling
> shell hasn't defined it...

s/probably/definitly/


regards,
	Holger 

On 24 Sep 2007, at 4:05 pm, Kay Bieri wrote:

>> Anybody has seen this or knows how to efficiently debug this?
>>
>> The postinst of htdig (1:3.2.0b6-3.1) fails on the call to  
>> htdigconfig when
>> it's called from inside fai -N softupdate, but not when called  
>> manually or
>> from within a normal apt or aptitude session.
>>
>> The error is "htfuzzy: '1' is not a supported algorithm."
>
> I had the same problem some time ago. htdig uses an environmental  
> variable $verbose, which fai uses as well. fai sets it to 1,  
> whereas htdig probably expect '-v' or something. Here are the  
> relevant lines from /usr/sbin/htdicconfig:
> ----
> if [ ! -f /var/lib/htdig/word2root.db ]
> then
>     htfuzzy $verbose endings
> fi
>
> if [ ! -f /var/lib/htdig/synonyms.db ]
> then
>     htfuzzy $verbose synonyms
> fi
> ----
>
> I "solved" the problem by preseeding debconf to skip the config  
> part and called htdigconfig in a hook afterwards:
> verbose= $ROOTCMD /usr/sbin/htdigconfig

Attachment: pgpa7kx6rNImN.pgp
Description: PGP signature


Reply to: